summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-28 16:37:26 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-28 16:37:38 +0100
commit1444cbcee0fe1061111202ec1114dc5d04623eb5 (patch)
tree6d8d8f301116e1eb40d5c51adc7b06f183a5e672 /app-mobilephone
parenteclass/ros-catkin.eclass: Build all ROS packages in C++11 mode. (diff)
downloadgentoo-1444cbcee0fe1061111202ec1114dc5d04623eb5.tar.gz
gentoo-1444cbcee0fe1061111202ec1114dc5d04623eb5.tar.bz2
gentoo-1444cbcee0fe1061111202ec1114dc5d04623eb5.zip
app-mobilephone/past: EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch4
-rw-r--r--app-mobilephone/past/past-0.0.4.ebuild17
2 files changed, 12 insertions, 9 deletions
diff --git a/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch b/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch
index d2a82e025688..e04de42b7ef8 100644
--- a/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch
+++ b/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch
@@ -1,5 +1,5 @@
---- src/device.cpp
-+++ src/device.cpp
+--- A/src/device.cpp
++++ B/src/device.cpp
@@ -22,6 +22,7 @@
extern "C" {
diff --git a/app-mobilephone/past/past-0.0.4.ebuild b/app-mobilephone/past/past-0.0.4.ebuild
index 8966954ef363..e1fc18d886d3 100644
--- a/app-mobilephone/past/past-0.0.4.ebuild
+++ b/app-mobilephone/past/past-0.0.4.ebuild
@@ -1,23 +1,26 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
+
inherit cmake-utils
-DESCRIPTION="A simple SMS tool"
-HOMEPAGE="http://www.kde-apps.org/content/show.php/past+-+SMS+Tool?content=74036"
-SRC_URI="http://www.kde-apps.org/CONTENT/content-files/74036-${P}.tar.bz2"
+DESCRIPTION="Simple SMS tool"
+HOMEPAGE="https://www.linux-apps.com/content/show.php/past+-+SMS+Tool?content=74036"
+SRC_URI="https://dl.opendesktop.org/api/files/download/id/1466626318/74036-${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-DEPEND="dev-qt/qtcore:4
+DEPEND="
+ app-mobilephone/gnokii[sms]
+ dev-qt/qtcore:4
dev-qt/qtdbus:4
dev-qt/qtgui:4
- app-mobilephone/gnokii[sms]"
+"
RDEPEND="${DEPEND}"
DOCS=( ChangeLog TODO )