summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-07 00:31:58 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-07 00:31:58 +0100
commit7f7cb0b77d1512de8dd8143ddcceb4416b497176 (patch)
treeb208bdb717fe7096d49e10e4512f3364bd6929ef /app-mobilephone
parentapp-mobilephone/wammu: Test LINGUAS rather than linguas_* USE flags. (diff)
downloadgentoo-7f7cb0b77d1512de8dd8143ddcceb4416b497176.tar.gz
gentoo-7f7cb0b77d1512de8dd8143ddcceb4416b497176.tar.bz2
gentoo-7f7cb0b77d1512de8dd8143ddcceb4416b497176.zip
app-mobilephone/gammu: Test LINGUAS rather than linguas_* USE flags.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gammu/gammu-1.33.0-r1.ebuild19
-rw-r--r--app-mobilephone/gammu/gammu-1.36.8.ebuild19
2 files changed, 8 insertions, 30 deletions
diff --git a/app-mobilephone/gammu/gammu-1.33.0-r1.ebuild b/app-mobilephone/gammu/gammu-1.33.0-r1.ebuild
index f447b749a0bf..f625885a66b4 100644
--- a/app-mobilephone/gammu/gammu-1.33.0-r1.ebuild
+++ b/app-mobilephone/gammu/gammu-1.33.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -34,9 +34,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# sys-devel/gettext is needed for creating .mo files
# Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
MY_AVAILABLE_LINGUAS=" af ar bg ca cs da de el en_GB es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv sw tr zh_CN zh_TW"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
PATCHES=(
"${FILESDIR}/${PN}-skip-locktest.patch"
@@ -50,21 +48,12 @@ pkg_setup() {
src_prepare() {
cmake-utils_src_prepare
- local lang support_linguas=no
+ local lang
for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if use linguas_${lang} ; then
- support_linguas=yes
- break
+ if ! has ${lang} ${LINGUAS-${lang}} ; then
+ rm -rf locale/${lang} || die
fi
done
- # install all languages when all selected LINGUAS aren't supported
- if [ "${support_linguas}" = "yes" ]; then
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if ! use linguas_${lang} ; then
- rm -rf locale/${lang} || die
- fi
- done
- fi
}
src_configure() {
diff --git a/app-mobilephone/gammu/gammu-1.36.8.ebuild b/app-mobilephone/gammu/gammu-1.36.8.ebuild
index 0f6cb475dc5d..c9f4dafca20e 100644
--- a/app-mobilephone/gammu/gammu-1.36.8.ebuild
+++ b/app-mobilephone/gammu/gammu-1.36.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -36,9 +36,7 @@ RDEPEND="
# sys-devel/gettext is needed for creating .mo files
# Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
MY_AVAILABLE_LINGUAS=" af ar bg bn ca cs da de el en_GB es et fi fr gl he hu id it ko nl pl pt_BR ro ru sk sv sw tr zh_CN zh_TW"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
PATCHES=(
"${FILESDIR}/${PN}-skip-locktest.patch"
@@ -48,21 +46,12 @@ PATCHES=(
src_prepare() {
cmake-utils_src_prepare
- local lang support_linguas=no
+ local lang
for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if use linguas_${lang} ; then
- support_linguas=yes
- break
+ if ! has ${lang} ${LINGUAS-${lang}} ; then
+ rm -rf locale/${lang} || die
fi
done
- # install all languages when all selected LINGUAS aren't supported
- if [ "${support_linguas}" = "yes" ]; then
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if ! use linguas_${lang} ; then
- rm -rf locale/${lang} || die
- fi
- done
- fi
}
src_configure() {