summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-02-25 22:53:23 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-02-25 22:54:27 +0100
commit85916a1e6c7c7936c5653dbc1a0d7c23e8718a97 (patch)
treeee3fff72992f4c3c26d4aa6fefe6b200c3f73c40 /app-office/calcurse
parentmedia-libs/taglib-extras: EAPI-7 bump (diff)
downloadgentoo-85916a1e6c7c7936c5653dbc1a0d7c23e8718a97.tar.gz
gentoo-85916a1e6c7c7936c5653dbc1a0d7c23e8718a97.tar.bz2
gentoo-85916a1e6c7c7936c5653dbc1a0d7c23e8718a97.zip
app-office/calcurse: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-office/calcurse')
-rw-r--r--app-office/calcurse/Manifest1
-rw-r--r--app-office/calcurse/calcurse-4.4.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-office/calcurse/Manifest b/app-office/calcurse/Manifest
index 9f074535d008..e38d2b49e773 100644
--- a/app-office/calcurse/Manifest
+++ b/app-office/calcurse/Manifest
@@ -1 +1,2 @@
DIST calcurse-4.3.0.tar.gz 597490 BLAKE2B 7fe31fc09cae12438173d4846a1e4b0a55f9e9416ab23ffc8b78e9d0f621072d8aca96b4161d5659db088e1007f685228e9669aae2d5606939c6564252826e1d SHA512 d948354b512d406f4915ce37107d3f529031e7698d7b38465913ff37120a93283e01f09f5267ebb19bf39ea133d6fac579b218d6dfd6056003b6222f9038f4b3
+DIST calcurse-4.4.0.tar.gz 620263 BLAKE2B 8fbe875f5e757ec3c11b9c23a994260403ee990bfcb3d4c41eefbf06a6db9e76cd5157e32b11c3fdc049896d5db3a9856862724902dab1cb48e0b00ef5df6f73 SHA512 43d30ad68bb39aaa9460644a691e66cbb15b9930737581583da65d00214c70fb1148a0edeca4430abb7a5cef2821b0f4c6fdbed8188d9ea5da5fedc4f95fa07c
diff --git a/app-office/calcurse/calcurse-4.4.0.ebuild b/app-office/calcurse/calcurse-4.4.0.ebuild
new file mode 100644
index 000000000000..0ce4d324c9e2
--- /dev/null
+++ b/app-office/calcurse/calcurse-4.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="a text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/httplib2
+ sys-libs/ncurses:0="
+
+DEPEND="
+ ${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2.1-tinfo.patch
+)
+
+# Most tests fail.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+}
+
+src_install() {
+ multilib-minimal_src_install
+}