summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-16 17:20:59 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-16 17:20:59 +0100
commit9699b1c310d94b9a4c76336a5f0a4aebe2589e91 (patch)
tree4cf50b74337ddf92d576bce567f08042728ce5d1 /app-office/calligra
parentkde-misc/wacomtablet: Disable test requiring DBus (diff)
downloadgentoo-9699b1c310d94b9a4c76336a5f0a4aebe2589e91.tar.gz
gentoo-9699b1c310d94b9a4c76336a5f0a4aebe2589e91.tar.bz2
gentoo-9699b1c310d94b9a4c76336a5f0a4aebe2589e91.zip
app-office/calligra: Fix build with poppler-0.73
Closes: https://bugs.gentoo.org/675454 Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/calligra')
-rw-r--r--app-office/calligra/calligra-3.1.0-r3.ebuild1
-rw-r--r--app-office/calligra/files/calligra-3.1.0-poppler-0.73.patch35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-office/calligra/calligra-3.1.0-r3.ebuild b/app-office/calligra/calligra-3.1.0-r3.ebuild
index 329a851fea6d..24ca06bcb3ab 100644
--- a/app-office/calligra/calligra-3.1.0-r3.ebuild
+++ b/app-office/calligra/calligra-3.1.0-r3.ebuild
@@ -121,6 +121,7 @@ PATCHES=(
"${FILESDIR}"/${P}-poppler-0.69.patch
"${FILESDIR}"/${P}-poppler-0.71.patch
"${FILESDIR}"/${P}-poppler-0.72.patch # not upstreamable
+ "${FILESDIR}"/${P}-poppler-0.73.patch
"${FILESDIR}"/${P}-no-webkit.patch
)
diff --git a/app-office/calligra/files/calligra-3.1.0-poppler-0.73.patch b/app-office/calligra/files/calligra-3.1.0-poppler-0.73.patch
new file mode 100644
index 000000000000..727f6edf3f12
--- /dev/null
+++ b/app-office/calligra/files/calligra-3.1.0-poppler-0.73.patch
@@ -0,0 +1,35 @@
+From a1ddd91e6c354e8f0dda40f8a522053c3fa19c39 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Tue, 15 Jan 2019 22:24:08 +0100
+Subject: Guchar -> unsigned char
+
+It was just a typdef and it's now gone
+---
+ filters/karbon/pdf/SvgOutputDev.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
+index 80f01a5..1a5aa30b 100644
+--- a/filters/karbon/pdf/SvgOutputDev.cpp
++++ b/filters/karbon/pdf/SvgOutputDev.cpp
+@@ -496,7 +496,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
+ if (maskColors) {
+ for (int y = 0; y < height; y++) {
+ dest = (unsigned int *)(buffer + y * 4 * width);
+- Guchar * pix = imgStr->getLine();
++ unsigned char * pix = imgStr->getLine();
+ colorMap->getRGBLine(pix, dest, width);
+
+ for (int x = 0; x < width; x++) {
+@@ -515,7 +515,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
+ } else {
+ for (int y = 0; y < height; y++) {
+ dest = (unsigned int *)(buffer + y * 4 * width);
+- Guchar * pix = imgStr->getLine();
++ unsigned char * pix = imgStr->getLine();
+ colorMap->getRGBLine(pix, dest, width);
+ }
+
+--
+cgit v1.1
+