summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/dia2code
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/dia2code')
-rw-r--r--app-office/dia2code/Manifest1
-rw-r--r--app-office/dia2code/dia2code-0.8.7.ebuild25
-rw-r--r--app-office/dia2code/files/dia2code-0.8.5-ar.patch24
-rw-r--r--app-office/dia2code/metadata.xml8
4 files changed, 58 insertions, 0 deletions
diff --git a/app-office/dia2code/Manifest b/app-office/dia2code/Manifest
new file mode 100644
index 000000000000..eb50abe82862
--- /dev/null
+++ b/app-office/dia2code/Manifest
@@ -0,0 +1 @@
+DIST dia2code-0.8.7.tar.gz 173733 SHA256 bebeeea56370bea416241128502144736d54d560b32d875174c5927089843adf SHA512 b02eea93488ab388aa6560ed62aef68d8d0f33e8ebf0237122d5038fd007dd1035180bcfe818edbdeb825d7767553d5c8f115acf57fce8085676cfbf6cb821e3 WHIRLPOOL 43e68f100ceca7acbd062847150086fa7c25edd5c0a819970d5e676ed6037d5d3140807cd57a0784d45cc863178521d721015b253bd745d37c73cb037fbbfa7b
diff --git a/app-office/dia2code/dia2code-0.8.7.ebuild b/app-office/dia2code/dia2code-0.8.7.ebuild
new file mode 100644
index 000000000000..611c791896e6
--- /dev/null
+++ b/app-office/dia2code/dia2code-0.8.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Convert UML diagrams produced with Dia to various source code flavours"
+HOMEPAGE="http://dia2code.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND="dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ gnome2_src_install
+ doman dia2code.1
+}
diff --git a/app-office/dia2code/files/dia2code-0.8.5-ar.patch b/app-office/dia2code/files/dia2code-0.8.5-ar.patch
new file mode 100644
index 000000000000..308b2fc8169f
--- /dev/null
+++ b/app-office/dia2code/files/dia2code-0.8.5-ar.patch
@@ -0,0 +1,24 @@
+--- configure.in 2012-07-07 15:52:28.000000000 +0200
++++ configure.in 2013-05-31 21:56:05.155859911 +0200
+@@ -8,6 +8,10 @@
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_RANLIB
++AN_MAKEVAR([AR], [AC_PROG_AR])
++AN_PROGRAM([ar], [AC_PROG_AR])
++AC_DEFUN([AC_PROG_AR], [AC_CHECK_TOOL(AR, ar, :)])
++AC_PROG_AR
+ dnl Checks for libraries.
+
+ AC_PATH_PROG(XML_CONFIG, xml2-config, no)
+--- dia2code/Makefile.in 2007-01-06 18:34:14.000000000 +0100
++++ dia2code/Makefile.in 2013-05-31 21:56:46.765920940 +0200
+@@ -208,7 +208,7 @@
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)
+
+-AR = ar
++AR = @AR@
+
+ clean-noinstLIBRARIES:
+ -test -z "$(noinst_LIBRARIES)" || rm -f $(noinst_LIBRARIES)
diff --git a/app-office/dia2code/metadata.xml b/app-office/dia2code/metadata.xml
new file mode 100644
index 000000000000..344ede1bdad6
--- /dev/null
+++ b/app-office/dia2code/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-office</herd>
+ <upstream>
+ <remote-id type="sourceforge">dia2code</remote-id>
+ </upstream>
+</pkgmetadata>