summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall T. Vasquez <ran.dall@icloud.com>2022-07-11 11:10:51 -0700
committerSam James <sam@gentoo.org>2022-07-12 03:46:49 +0100
commit0109dc9d1728c17f972b69d711787ff8057dcd3f (patch)
tree455daa60cfac64d1743a48ad69f89551e3b84a3a /app-office/gtg
parentapp-office/gtg: add ebuild for 0.6 (diff)
downloadgentoo-0109dc9d1728c17f972b69d711787ff8057dcd3f.tar.gz
gentoo-0109dc9d1728c17f972b69d711787ff8057dcd3f.tar.bz2
gentoo-0109dc9d1728c17f972b69d711787ff8057dcd3f.zip
app-office/gtg: drop 0.4.0
Signed-off-by: Randall T. Vasquez <ran.dall@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/26269 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office/gtg')
-rw-r--r--app-office/gtg/gtg-0.4.0.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-office/gtg/gtg-0.4.0.ebuild b/app-office/gtg/gtg-0.4.0.ebuild
deleted file mode 100644
index e16de2b4bc69..000000000000
--- a/app-office/gtg/gtg-0.4.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_{7..8} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit meson python-single-r1 xdg
-
-DESCRIPTION="Personal organizer for the GNOME desktop environment"
-HOMEPAGE="https://wiki.gnome.org/Apps/GTG/"
-SRC_URI="https://github.com/getting-things-gnome/gtg/releases/download/v0.4/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- >=dev-python/liblarch-3.0[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- ')
- x11-libs/pango[introspection]
- x11-libs/gdk-pixbuf[introspection]
- x11-libs/gtk+:3[introspection]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-util/itstool
- >=sys-devel/gettext-0.19.8
- test? ( $(python_gen_cond_dep '
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/cheetah3[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- ')
- || ( app-text/pdfjam >=app-text/texlive-core-2021 )
- app-text/pdftk
- dev-texlive/texlive-latex
- )
-"
-
-src_install() {
- meson_src_install
- python_fix_shebang "${ED}"/usr/bin/gtg
- python_optimize
-}
-
-src_test() {
- nosetests -v || die
-}