summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-19 09:44:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-19 10:04:39 +0200
commitd62a54b83ee8fdaa26f20c3735cf0b6af6311df2 (patch)
tree821ff254f60d7723e502ebcfff7273f6a7622613 /app-office/ledger
parentapp-misc/resolve-march-native: Remove old (diff)
downloadgentoo-d62a54b83ee8fdaa26f20c3735cf0b6af6311df2.tar.gz
gentoo-d62a54b83ee8fdaa26f20c3735cf0b6af6311df2.tar.bz2
gentoo-d62a54b83ee8fdaa26f20c3735cf0b6af6311df2.zip
app-office/ledger: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-office/ledger')
-rw-r--r--app-office/ledger/Manifest1
-rw-r--r--app-office/ledger/ledger-3.1.2-r1.ebuild117
2 files changed, 0 insertions, 118 deletions
diff --git a/app-office/ledger/Manifest b/app-office/ledger/Manifest
index e1a42967e27e..6a76f7654522 100644
--- a/app-office/ledger/Manifest
+++ b/app-office/ledger/Manifest
@@ -1,2 +1 @@
-DIST ledger-3.1.2.tar.gz 801112 BLAKE2B 71b907a83fe10857d17de746c0d124572859c9eca237130ebbfa5b730406470a5d31025736e80516feaac7daf14a4edb8b644ed72a0827f9714ac9cb2b79c0fb SHA512 445d9a9c70aa3e59718f8fb75e4110c73f2f476436149fdd456b5fe7b9cee9333c09647080049989599dfac491e5bdd0d143717e58e15989db0fcaad4e5a958d
DIST ledger-3.2.0.tar.gz 790404 BLAKE2B 081ca5d857238aecbeae5a0ba3267864442a8c1772a71b1894f5a9fb33173f9a0bd488ad4db3844fce8172268e516ebb92ba0556ced6e67b2a089fbb5adfde36 SHA512 580f4f39d7c3cd2bd1d05bcc36b127cfb311219f39fe50dbf23f582f73dd986729d4b5fa76bfd89cd5db9bfdfcdd5dca5b9d6b24766650040e45b881726e65ea
diff --git a/app-office/ledger/ledger-3.1.2-r1.ebuild b/app-office/ledger/ledger-3.1.2-r1.ebuild
deleted file mode 100644
index df1fb4549849..000000000000
--- a/app-office/ledger/ledger-3.1.2-r1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit check-reqs cmake-utils python-single-r1
-
-DESCRIPTION="A double-entry accounting system with a command-line reporting interface"
-HOMEPAGE="https://www.ledger-cli.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD"
-KEYWORDS="amd64 x86"
-SLOT="0"
-IUSE="debug doc emacs python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="test"
-
-CHECKREQS_MEMORY=8G
-
-RDEPEND="
- dev-libs/boost:=[python?]
- dev-libs/gmp:0=
- dev-libs/mpfr:0=
- python? (
- $(python_gen_cond_dep '
- dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
- ')
- dev-python/cheetah
- ${PYTHON_DEPS}
- )
-"
-DEPEND="
- ${RDEPEND}
- dev-libs/utfcpp
- doc? (
- sys-apps/texinfo
- virtual/texi2dvi
- dev-texlive/texlive-fontsrecommended
- )
-"
-
-# Building with python integration seems to fail without 8G available
-# RAM(!) Since the memory check in check-reqs doesn't count swap, it
-# may be unfair to fail the build entirely on the memory test alone.
-# Therefore check-reqs_pkg_pretend is deliberately omitted so that we
-# ewarn but not eerror.
-pkg_pretend() {
- :
-}
-
-pkg_setup() {
- if use python; then
- check-reqs_pkg_setup
- python-single-r1_pkg_setup
- fi
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- if ! has_version ">=dev-libs/boost-1.70"; then
- sed -r -i \
- -e '/set.BOOST_PYTHON/s/python27/python-2.7/g' \
- "${S}/CMakeLists.txt" \
- || die "Failed to update CMakeLists.txt for python2.7 boost"
- fi
-
- # Want to type "info ledger" not "info ledger3"
- sed -i -e 's/ledger3/ledger/g' \
- doc/ledger3.texi \
- doc/CMakeLists.txt \
- test/CheckTexinfo.py \
- tools/cleanup.sh \
- tools/gendocs.sh \
- tools/prepare-commit-msg \
- tools/spellcheck.sh \
- || die "Failed to update info file name in file contents"
-
- mv doc/ledger{3,}.texi || die "Failed to rename info file name"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOCS="$(usex doc)"
- -DBUILD_WEB_DOCS="$(usex doc)"
- -DUSE_PYTHON="$(usex python)"
- -DCMAKE_INSTALL_DOCDIR="/usr/share/doc/${PF}"
- -DCMAKE_BUILD_WITH_INSTALL_RPATH:BOOL=ON
- -DBUILD_DEBUG="$(usex debug)"
- -DUSE_PYTHON27_COMPONENT=yes
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- use doc && cmake-utils_src_make doc
-}
-
-src_install() {
- cmake-utils_src_install
-}
-
-pkg_postinst() {
- elog
- elog "Since version 3, vim support is released separately."
- elog "See https://github.com/ledger/vim-ledger"
- elog
- elog "For Emacs mode, emerge app-emacs/ledger-mode"
-}
-
-# rainy day TODO:
-# - IUSE test