summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-13 22:18:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 00:18:38 +0100
commit2d79721b639c9a5870f808685c9a2c0a367ed9f9 (patch)
tree2bbf2bdf22e1e16269bcff92c343fcb96022f7e7 /app-office/libreoffice
parentdev-python/jira: allow dev-python/pycryptodome as well as dev-python/pycrypto... (diff)
downloadgentoo-2d79721b639c9a5870f808685c9a2c0a367ed9f9.tar.gz
gentoo-2d79721b639c9a5870f808685c9a2c0a367ed9f9.tar.bz2
gentoo-2d79721b639c9a5870f808685c9a2c0a367ed9f9.zip
app-office/libreoffice: Add gnome-base/dconf to USE=eds as well
It simplifies REQUIRED_USE further, esp. with gtk3 still not being stable. Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/libreoffice-5.4.9999.ebuild18
-rw-r--r--app-office/libreoffice/libreoffice-6.0.9999.ebuild18
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild18
3 files changed, 33 insertions, 21 deletions
diff --git a/app-office/libreoffice/libreoffice-5.4.9999.ebuild b/app-office/libreoffice/libreoffice-5.4.9999.ebuild
index 201395b5c801..7215809cdb33 100644
--- a/app-office/libreoffice/libreoffice-5.4.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-5.4.9999.ebuild
@@ -139,6 +139,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
dbus? ( dev-libs/dbus-glib )
eds? (
dev-libs/glib:2
+ gnome-base/dconf
gnome-extra/evolution-data-server
)
firebird? ( >=dev-db/firebird-3.0.2.32703.0-r1 )
@@ -231,7 +232,6 @@ DEPEND="${COMMON_DEPEND}
REQUIRED_USE="${PYTHON_REQUIRED_USE}
bluetooth? ( dbus )
collada? ( gltf )
- eds? ( gtk3 )
libreoffice_extensions_nlpsolver? ( java )
libreoffice_extensions_scripting-beanshell? ( java )
libreoffice_extensions_scripting-javascript? ( java )
@@ -349,8 +349,7 @@ src_prepare() {
}
src_configure() {
- local java_opts
- local ext_opts
+ local ext_opts gtk_opts java_opts
# Set up Google API keys, see https://www.chromium.org/developers/how-tos/api-keys
# Note: these are for Gentoo use ONLY. For your own distribution, please get
@@ -378,6 +377,12 @@ src_configure() {
fi
done
+ if use eds || use gtk3; then
+ gtk_opts=( --enable-dconf --enable-gio )
+ else
+ gtk_opts=( --disable-dconf --disable-gio )
+ fi
+
if use java; then
# hsqldb: system one is too new
java_opts="
@@ -465,8 +470,6 @@ src_configure() {
$(use_enable gstreamer gstreamer-1-0) \
$(use_enable gtk) \
$(use_enable gtk3) \
- $(use_enable gtk3 dconf) \
- $(use_enable gtk3 gio) \
$(use_enable kde kde4) \
$(use_enable mysql ext-mariadb-connector) \
$(use_enable odk) \
@@ -482,8 +485,9 @@ src_configure() {
$(use_with java) \
$(use_with mysql system-mysql-cppconn) \
$(use_with odk doxygen) \
- ${java_opts} \
- ${ext_opts}
+ ${ext_opts} \
+ ${gtk_opts[@]} \
+ ${java_opts}
}
src_compile() {
diff --git a/app-office/libreoffice/libreoffice-6.0.9999.ebuild b/app-office/libreoffice/libreoffice-6.0.9999.ebuild
index 6033b315d7eb..e489cde34e3b 100644
--- a/app-office/libreoffice/libreoffice-6.0.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.0.9999.ebuild
@@ -139,6 +139,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
dbus? ( dev-libs/dbus-glib )
eds? (
dev-libs/glib:2
+ gnome-base/dconf
gnome-extra/evolution-data-server
)
firebird? ( >=dev-db/firebird-3.0.2.32703.0-r1 )
@@ -234,7 +235,6 @@ DEPEND="${COMMON_DEPEND}
REQUIRED_USE="${PYTHON_REQUIRED_USE}
bluetooth? ( dbus )
- eds? ( gtk3 )
kde? ( || ( qt4 qt5 ) )
libreoffice_extensions_nlpsolver? ( java )
libreoffice_extensions_scripting-beanshell? ( java )
@@ -354,8 +354,7 @@ src_prepare() {
}
src_configure() {
- local java_opts
- local ext_opts
+ local ext_opts gtk_opts java_opts
# Set up Google API keys, see https://www.chromium.org/developers/how-tos/api-keys
# Note: these are for Gentoo use ONLY. For your own distribution, please get
@@ -378,6 +377,12 @@ src_configure() {
fi
done
+ if use eds || use gtk3; then
+ gtk_opts=( --enable-dconf --enable-gio )
+ else
+ gtk_opts=( --disable-dconf --disable-gio )
+ fi
+
if use java; then
# hsqldb: system one is too new
java_opts="
@@ -468,8 +473,6 @@ src_configure() {
$(use_enable gstreamer gstreamer-1-0) \
$(use_enable gtk) \
$(use_enable gtk3) \
- $(use_enable gtk3 dconf) \
- $(use_enable gtk3 gio) \
$(use_enable mysql ext-mariadb-connector) \
$(use_enable odk) \
$(use_enable pdfimport) \
@@ -483,8 +486,9 @@ src_configure() {
$(use_with java) \
$(use_with mysql system-mysql-cppconn) \
$(use_with odk doxygen) \
- ${java_opts} \
- ${ext_opts}
+ ${ext_opts} \
+ ${gtk_opts[@]} \
+ ${java_opts}
}
src_compile() {
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 6033b315d7eb..e489cde34e3b 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -139,6 +139,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
dbus? ( dev-libs/dbus-glib )
eds? (
dev-libs/glib:2
+ gnome-base/dconf
gnome-extra/evolution-data-server
)
firebird? ( >=dev-db/firebird-3.0.2.32703.0-r1 )
@@ -234,7 +235,6 @@ DEPEND="${COMMON_DEPEND}
REQUIRED_USE="${PYTHON_REQUIRED_USE}
bluetooth? ( dbus )
- eds? ( gtk3 )
kde? ( || ( qt4 qt5 ) )
libreoffice_extensions_nlpsolver? ( java )
libreoffice_extensions_scripting-beanshell? ( java )
@@ -354,8 +354,7 @@ src_prepare() {
}
src_configure() {
- local java_opts
- local ext_opts
+ local ext_opts gtk_opts java_opts
# Set up Google API keys, see https://www.chromium.org/developers/how-tos/api-keys
# Note: these are for Gentoo use ONLY. For your own distribution, please get
@@ -378,6 +377,12 @@ src_configure() {
fi
done
+ if use eds || use gtk3; then
+ gtk_opts=( --enable-dconf --enable-gio )
+ else
+ gtk_opts=( --disable-dconf --disable-gio )
+ fi
+
if use java; then
# hsqldb: system one is too new
java_opts="
@@ -468,8 +473,6 @@ src_configure() {
$(use_enable gstreamer gstreamer-1-0) \
$(use_enable gtk) \
$(use_enable gtk3) \
- $(use_enable gtk3 dconf) \
- $(use_enable gtk3 gio) \
$(use_enable mysql ext-mariadb-connector) \
$(use_enable odk) \
$(use_enable pdfimport) \
@@ -483,8 +486,9 @@ src_configure() {
$(use_with java) \
$(use_with mysql system-mysql-cppconn) \
$(use_with odk doxygen) \
- ${java_opts} \
- ${ext_opts}
+ ${ext_opts} \
+ ${gtk_opts[@]} \
+ ${java_opts}
}
src_compile() {