summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-11-21 21:01:19 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-11-21 21:01:54 +0200
commit883a8fcde2ae0e61193132f7964978ec003cfb01 (patch)
treed1fd4775ec95947ee162faaf9e0e86102c8de96a /app-office/libreoffice
parentapp-office/libreoffice: Use CLANG_CC in 7.0 branch (diff)
downloadgentoo-883a8fcde2ae0e61193132f7964978ec003cfb01.tar.gz
gentoo-883a8fcde2ae0e61193132f7964978ec003cfb01.tar.bz2
gentoo-883a8fcde2ae0e61193132f7964978ec003cfb01.zip
app-office/libreoffice: Enforce consistent llvm and clang
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/libreoffice-7.0.3.1.ebuild14
-rw-r--r--app-office/libreoffice/libreoffice-7.0.9999.ebuild14
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild14
3 files changed, 33 insertions, 9 deletions
diff --git a/app-office/libreoffice/libreoffice-7.0.3.1.ebuild b/app-office/libreoffice/libreoffice-7.0.3.1.ebuild
index b7f883af3784..75e3660ccfa3 100644
--- a/app-office/libreoffice/libreoffice-7.0.3.1.ebuild
+++ b/app-office/libreoffice/libreoffice-7.0.3.1.ebuild
@@ -183,9 +183,17 @@ COMMON_DEPEND="${PYTHON_DEPS}
net-wireless/bluez
)
clang? (
- sys-devel/clang
- sys-devel/llvm
- sys-devel/lld
+ || (
+ ( sys-devel/clang:10
+ sys-devel/llvm:10
+ =sys-devel/lld-10* )
+ ( sys-devel/clang:11
+ sys-devel/llvm:11
+ =sys-devel/lld-11* )
+ ( sys-devel/clang:12
+ sys-devel/llvm:12
+ =sys-devel/lld-12* )
+ )
)
coinmp? ( sci-libs/coinor-mp )
cups? ( net-print/cups )
diff --git a/app-office/libreoffice/libreoffice-7.0.9999.ebuild b/app-office/libreoffice/libreoffice-7.0.9999.ebuild
index 735ca0fa649d..5040a3e0391d 100644
--- a/app-office/libreoffice/libreoffice-7.0.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-7.0.9999.ebuild
@@ -183,9 +183,17 @@ COMMON_DEPEND="${PYTHON_DEPS}
net-wireless/bluez
)
clang? (
- sys-devel/clang
- sys-devel/llvm
- sys-devel/lld
+ || (
+ ( sys-devel/clang:10
+ sys-devel/llvm:10
+ =sys-devel/lld-10* )
+ ( sys-devel/clang:11
+ sys-devel/llvm:11
+ =sys-devel/lld-11* )
+ ( sys-devel/clang:12
+ sys-devel/llvm:12
+ =sys-devel/lld-12* )
+ )
)
coinmp? ( sci-libs/coinor-mp )
cups? ( net-print/cups )
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index d114626a09dc..1b78e99f05f5 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -183,9 +183,17 @@ COMMON_DEPEND="${PYTHON_DEPS}
net-wireless/bluez
)
clang? (
- sys-devel/clang
- sys-devel/llvm
- sys-devel/lld
+ || (
+ ( sys-devel/clang:10
+ sys-devel/llvm:10
+ =sys-devel/lld-10* )
+ ( sys-devel/clang:11
+ sys-devel/llvm:11
+ =sys-devel/lld-11* )
+ ( sys-devel/clang:12
+ sys-devel/llvm:12
+ =sys-devel/lld-12* )
+ )
)
coinmp? ( sci-libs/coinor-mp )
cups? ( net-print/cups )