summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-02-26 19:35:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-02-26 19:37:25 +0100
commitd09290006a6203b3fad5375584a98b2ce46ad8f1 (patch)
treee4b302086757bbb7652248b55b706522862d434b /app-office/libreoffice
parentapp-text/libstaroffice: 0.0.3 version bump (diff)
downloadgentoo-d09290006a6203b3fad5375584a98b2ce46ad8f1.tar.gz
gentoo-d09290006a6203b3fad5375584a98b2ce46ad8f1.tar.bz2
gentoo-d09290006a6203b3fad5375584a98b2ce46ad8f1.zip
app-office/libreoffice: Fix system-pyuno patch, missing deps
--disable-pdfium until it is packaged Thanks-to: jospezial <jospezial@gmx.de> Gentoo-bug: 609050, 609054 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch42
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild10
2 files changed, 49 insertions, 3 deletions
diff --git a/app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch b/app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch
new file mode 100644
index 000000000000..83b56d1a1927
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch
@@ -0,0 +1,42 @@
+--- a/desktop/scripts/soffice.sh
++++ a/desktop/scripts/soffice.sh
+@@ -147,6 +147,9 @@ if echo "$checks" | grep -q "cc" ; then
+ exit 1;
+ fi
+
++PYTHONPATH=$sd_prog${PYTHONPATH+:$PYTHONPATH}
++export PYTHONPATH
++
+ case "$(uname -s)" in
+ NetBSD|OpenBSD|DragonFly)
+ # this is a temporary hack until we can live with the default search paths
+--- a/pyuno/source/module/uno.py
++++ a/pyuno/source/module/uno.py
+@@ -16,11 +16,16 @@
+ # except in compliance with the License. You may obtain a copy of
+ # the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ #
++import os
+ import pyuno
+ import sys
+ import traceback
+ import warnings
+
++sys.path.append('%eprefix%/usr/%libdir%/libreoffice/program')
++if getattr(os.environ, 'URE_BOOTSTRAP', None) is None:
++ os.environ['URE_BOOTSTRAP'] = "vnd.sun.star.pathname:%eprefix%/usr/%libdir%/libreoffice/program/fundamentalrc"
++
+ # since on Windows sal3.dll no longer calls WSAStartup
+ import socket
+
+--- a/pyuno/source/officehelper.py
++++ a/pyuno/source/officehelper.py
+@@ -45,7 +45,7 @@ def bootstrap():
+ if "UNO_PATH" in os.environ:
+ sOffice = os.environ["UNO_PATH"]
+ else:
+- sOffice = "" # lets hope for the best
++ sOffice = "%eprefix%/usr/%libdir%/libreoffice/program"
+ sOffice = os.path.join(sOffice, "soffice")
+ if platform.startswith("win"):
+ sOffice += ".exe"
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index edc20fcdbb53..c2b9b736ca0f 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -89,7 +89,7 @@ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
COMMON_DEPEND="${PYTHON_DEPS}
app-arch/unzip
app-arch/zip
- app-crypt/gpgme
+ app-crypt/gpgme[cxx]
app-text/hunspell
>=app-text/libabw-0.1.0
>=app-text/libebook-0.1
@@ -112,6 +112,8 @@ COMMON_DEPEND="${PYTHON_DEPS}
dev-libs/expat
dev-libs/hyphen
dev-libs/icu:=
+ dev-libs/libassuan
+ dev-libs/libgpg-error
>=dev-libs/liborcus-0.12.1
dev-libs/librevenge
dev-libs/nspr
@@ -244,7 +246,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
PATCHES=(
# not upstreamable stuff
- "${FILESDIR}/${PN}-5.3-system-pyuno.patch"
+ "${FILESDIR}/${PN}-5.4-system-pyuno.patch"
# TODO: upstream
"${FILESDIR}/${PN}-5.2.5.1-glibc-2.24.patch"
@@ -434,6 +436,7 @@ src_configure() {
# --disable-report-builder: too much java packages pulled in without pkgs
# --without-system-sane: just sane.h header that is used for scan in writer,
# not linked or anything else, worthless to depend on
+ # --disable-pdfium: not yet packaged
econf \
--with-system-dicts \
--with-system-epoxy \
@@ -454,6 +457,7 @@ src_configure() {
--disable-fetch-external \
--disable-gstreamer-0-10 \
--disable-online-update \
+ --disable-pdfium \
--disable-report-builder \
--with-alloc=$(use jemalloc && echo "jemalloc" || echo "system") \
--with-build-version="Gentoo official package" \
@@ -471,7 +475,7 @@ src_configure() {
--without-myspell-dicts \
--without-help \
--with-helppack-integration \
- --with-system-gpgme \
+ --with-system-gpgmepp \
--without-system-sane \
$(use_enable bluetooth sdremote-bluetooth) \
$(use_enable coinmp) \