summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-01 16:54:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-01 19:39:21 +0100
commitdfa6d688436719d87a518dc7405675734e9591d8 (patch)
tree2dd9f5b382ba6a102600fa7827d6bc28835cd1c4 /app-office/libreoffice
parentapp-office/scribus: Fix build with poppler-0.82.0 (diff)
downloadgentoo-dfa6d688436719d87a518dc7405675734e9591d8.tar.gz
gentoo-dfa6d688436719d87a518dc7405675734e9591d8.tar.bz2
gentoo-dfa6d688436719d87a518dc7405675734e9591d8.zip
app-office/libreoffice: Fix build with poppler-0.82.0
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/files/libreoffice-6.2.8.2-poppler-0.82.patch123
-rw-r--r--app-office/libreoffice/libreoffice-6.2.8.2.ebuild1
-rw-r--r--app-office/libreoffice/libreoffice-6.3.3.2.ebuild6
3 files changed, 127 insertions, 3 deletions
diff --git a/app-office/libreoffice/files/libreoffice-6.2.8.2-poppler-0.82.patch b/app-office/libreoffice/files/libreoffice-6.2.8.2-poppler-0.82.patch
new file mode 100644
index 000000000000..b6c30cd92a16
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.2.8.2-poppler-0.82.patch
@@ -0,0 +1,123 @@
+From 2eadd46ab81058087af95bdfc1fea28fcdb65998 Mon Sep 17 00:00:00 2001
+From: Rasmus Thomsen <oss@cogitri.dev>
+Date: Sat, 26 Oct 2019 14:11:35 +0200
+Subject: Fix build with poppler-0.82
+
+Change-Id: I3b6b3faea7986f3e5a6ae4790580d03bc9c955fc
+Reviewed-on: https://gerrit.libreoffice.org/81545
+Tested-by: Jenkins
+Reviewed-by: Michael Stahl <michael.stahl@cib.de>
+---
+ .../pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 25 ++++++++++++++++++++++
+ .../pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 16 +++++++++++++-
+ 2 files changed, 40 insertions(+), 1 deletion(-)
+
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+index ce32a41..3ae3bdc 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+@@ -863,11 +863,20 @@ void PDFOutDev::eoClip(GfxState *state)
+ local offset of character (zero for horizontal writing mode). not
+ taken into account for output pos updates. Used for vertical writing.
+ */
++
++#if POPPLER_CHECK_VERSION(0, 82, 0)
++void PDFOutDev::drawChar(GfxState *state, double x, double y,
++ double dx, double dy,
++ double originX, double originY,
++ CharCode, int /*nBytes*/, const Unicode *u, int uLen)
++{
++#else
+ void PDFOutDev::drawChar(GfxState *state, double x, double y,
+ double dx, double dy,
+ double originX, double originY,
+ CharCode, int /*nBytes*/, Unicode *u, int uLen)
+ {
++#endif
+ assert(state);
+
+ if( u == nullptr )
+@@ -979,11 +988,19 @@ void PDFOutDev::drawImageMask(GfxState* pState, Object*, Stream* str,
+ writeBinaryBuffer(aBuf);
+ }
+
++#if POPPLER_CHECK_VERSION(0, 82, 0)
++void PDFOutDev::drawImage(GfxState*, Object*, Stream* str,
++ int width, int height, GfxImageColorMap* colorMap,
++ poppler_bool /*interpolate*/,
++ const int* maskColors, poppler_bool /*inlineImg*/ )
++{
++#else
+ void PDFOutDev::drawImage(GfxState*, Object*, Stream* str,
+ int width, int height, GfxImageColorMap* colorMap,
+ poppler_bool /*interpolate*/,
+ int* maskColors, poppler_bool /*inlineImg*/ )
+ {
++#endif
+ if (m_bSkipImages)
+ return;
+ OutputBuffer aBuf; initBuf(aBuf);
+@@ -1004,12 +1021,20 @@ void PDFOutDev::drawImage(GfxState*, Object*, Stream* str,
+ {
+ GfxRGB aMinRGB;
+ colorMap->getColorSpace()->getRGB(
++#if POPPLER_CHECK_VERSION(0, 82, 0)
++ reinterpret_cast<const GfxColor*>(maskColors),
++#else
+ reinterpret_cast<GfxColor*>(maskColors),
++#endif
+ &aMinRGB );
+
+ GfxRGB aMaxRGB;
+ colorMap->getColorSpace()->getRGB(
++#if POPPLER_CHECK_VERSION(0, 82, 0)
++ reinterpret_cast<const GfxColor*>(maskColors)+gfxColorMaxComps,
++#else
+ reinterpret_cast<GfxColor*>(maskColors)+gfxColorMaxComps,
++#endif
+ &aMaxRGB );
+
+ aMaskBuf.push_back( colToByte(aMinRGB.r) );
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+index 1a0c3f0..02f6b59 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+@@ -232,10 +232,17 @@ namespace pdfi
+ virtual void eoClip(GfxState *state) override;
+
+ //----- text drawing
++#if POPPLER_CHECK_VERSION(0, 82, 0)
++ virtual void drawChar(GfxState *state, double x, double y,
++ double dx, double dy,
++ double originX, double originY,
++ CharCode code, int nBytes, const Unicode *u, int uLen) override;
++#else
+ virtual void drawChar(GfxState *state, double x, double y,
+ double dx, double dy,
+ double originX, double originY,
+ CharCode code, int nBytes, Unicode *u, int uLen) override;
++#endif
+ #if POPPLER_CHECK_VERSION(0, 64, 0)
+ virtual void drawString(GfxState *state, const GooString *s) override;
+ #else
+@@ -248,10 +255,17 @@ namespace pdfi
+ int width, int height, poppler_bool invert,
+ poppler_bool interpolate,
+ poppler_bool inlineImg) override;
++#if POPPLER_CHECK_VERSION(0, 82, 0)
+ virtual void drawImage(GfxState *state, Object *ref, Stream *str,
+ int width, int height, GfxImageColorMap *colorMap,
+ poppler_bool interpolate,
+- int* maskColors, poppler_bool inlineImg) override;
++ const int* maskColors, poppler_bool inlineImg) override;
++#else
++ virtual void drawImage(GfxState *state, Object *ref, Stream *str,
++ int width, int height, GfxImageColorMap *colorMap,
++ poppler_bool interpolate,
++ int* maskColors, poppler_bool inlineImg) override;
++#endif
+ virtual void drawMaskedImage(GfxState *state, Object *ref, Stream *str,
+ int width, int height,
+ GfxImageColorMap *colorMap,
+--
+cgit v1.1
diff --git a/app-office/libreoffice/libreoffice-6.2.8.2.ebuild b/app-office/libreoffice/libreoffice-6.2.8.2.ebuild
index 6831dab51cb3..97acd86ab3ac 100644
--- a/app-office/libreoffice/libreoffice-6.2.8.2.ebuild
+++ b/app-office/libreoffice/libreoffice-6.2.8.2.ebuild
@@ -246,6 +246,7 @@ fi
PATCHES=(
# master branch
"${FILESDIR}/${PN}-6.2-ldap-optional.patch"
+ "${FILESDIR}/${P}-poppler-0.82.patch"
# "${WORKDIR}"/${PATCHSET/.tar.xz/}
# not upstreamable stuff
diff --git a/app-office/libreoffice/libreoffice-6.3.3.2.ebuild b/app-office/libreoffice/libreoffice-6.3.3.2.ebuild
index 0233e28a4fb1..c7fc98d14c9f 100644
--- a/app-office/libreoffice/libreoffice-6.3.3.2.ebuild
+++ b/app-office/libreoffice/libreoffice-6.3.3.2.ebuild
@@ -244,15 +244,15 @@ else
fi
PATCHES=(
+ # master branch
+ "${FILESDIR}/${P}-mysql-connector-c-8.patch" # bug #692422
+ "${FILESDIR}/${PN}-6.2.8.2-poppler-0.82.patch"
# "${WORKDIR}"/${PATCHSET/.tar.xz/}
# not upstreamable stuff
"${FILESDIR}/${PN}-5.4-system-pyuno.patch"
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
"${FILESDIR}/${PN}-6.1-nomancompress.patch"
-
- # master branch
- "${FILESDIR}/${P}-mysql-connector-c-8.patch" # bug #692422
)
S="${WORKDIR}/${PN}-${MY_PV}"