summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-14 08:52:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-14 19:36:10 +0100
commitf89cfb0e9f3afe471ff470d075c80379f749d163 (patch)
tree549f1127ead0ed1bef07701cfb101fbe4973326c /app-office/libreoffice
parentapp-office/libreoffice: Add USE ldap (diff)
downloadgentoo-f89cfb0e9f3afe471ff470d075c80379f749d163.tar.gz
gentoo-f89cfb0e9f3afe471ff470d075c80379f749d163.tar.bz2
gentoo-f89cfb0e9f3afe471ff470d075c80379f749d163.zip
app-office/libreoffice: Switch to xdg.eclass, drop gnome2-utils.eclass
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/libreoffice-6.2.1.1.ebuild18
-rw-r--r--app-office/libreoffice/libreoffice-6.2.9999.ebuild18
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild18
3 files changed, 15 insertions, 39 deletions
diff --git a/app-office/libreoffice/libreoffice-6.2.1.1.ebuild b/app-office/libreoffice/libreoffice-6.2.1.1.ebuild
index a49542b0993e..8116cd6766a8 100644
--- a/app-office/libreoffice/libreoffice-6.2.1.1.ebuild
+++ b/app-office/libreoffice/libreoffice-6.2.1.1.ebuild
@@ -21,7 +21,7 @@ BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
PATCHSET="${PN}-6.2.0.3-patchset-02.tar.xz"
[[ ${MY_PV} == *9999* ]] && inherit git-r3
-inherit autotools bash-completion-r1 check-reqs eapi7-ver flag-o-matic gnome2-utils java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg-utils
+inherit autotools bash-completion-r1 check-reqs eapi7-ver flag-o-matic java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg
DESCRIPTION="A full office productivity suite"
HOMEPAGE="https://www.libreoffice.org"
@@ -287,7 +287,6 @@ pkg_pretend() {
pkg_setup() {
java-pkg-opt-2_pkg_setup
python-single-r1_pkg_setup
- xdg_environment_reset
[[ ${MERGE_TYPE} != binary ]] && _check_reqs pkg_setup
}
@@ -311,7 +310,7 @@ src_unpack() {
}
src_prepare() {
- default
+ xdg_src_prepare
# sandbox violations on many systems, we don't need it. Bug #646406
sed -i \
@@ -571,14 +570,7 @@ src_install() {
pax-mark -m "${ED%/}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
}
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
+pkg_preinst() {
+ java-utils-2_pkg_preinst
+ xdg_pkg_preinst
}
diff --git a/app-office/libreoffice/libreoffice-6.2.9999.ebuild b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
index bc72c7c13fdd..9b20bec5816e 100644
--- a/app-office/libreoffice/libreoffice-6.2.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
@@ -21,7 +21,7 @@ BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
PATCHSET="${PN}-6.2.0.3-patchset-02.tar.xz"
[[ ${MY_PV} == *9999* ]] && inherit git-r3
-inherit autotools bash-completion-r1 check-reqs eapi7-ver flag-o-matic gnome2-utils java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg-utils
+inherit autotools bash-completion-r1 check-reqs eapi7-ver flag-o-matic java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg
DESCRIPTION="A full office productivity suite"
HOMEPAGE="https://www.libreoffice.org"
@@ -286,7 +286,6 @@ pkg_pretend() {
pkg_setup() {
java-pkg-opt-2_pkg_setup
python-single-r1_pkg_setup
- xdg_environment_reset
[[ ${MERGE_TYPE} != binary ]] && _check_reqs pkg_setup
}
@@ -310,7 +309,7 @@ src_unpack() {
}
src_prepare() {
- default
+ xdg_src_prepare
# sandbox violations on many systems, we don't need it. Bug #646406
sed -i \
@@ -570,14 +569,7 @@ src_install() {
pax-mark -m "${ED%/}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
}
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
+pkg_preinst() {
+ java-utils-2_pkg_preinst
+ xdg_pkg_preinst
}
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index b86252e215d4..66452c403fbd 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -21,7 +21,7 @@ BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
# PATCHSET="${P}-patchset-01.tar.xz"
[[ ${MY_PV} == *9999* ]] && inherit git-r3
-inherit autotools bash-completion-r1 check-reqs eapi7-ver flag-o-matic gnome2-utils java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg-utils
+inherit autotools bash-completion-r1 check-reqs eapi7-ver flag-o-matic java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg
DESCRIPTION="A full office productivity suite"
HOMEPAGE="https://www.libreoffice.org"
@@ -282,7 +282,6 @@ pkg_pretend() {
pkg_setup() {
java-pkg-opt-2_pkg_setup
python-single-r1_pkg_setup
- xdg_environment_reset
[[ ${MERGE_TYPE} != binary ]] && _check_reqs pkg_setup
}
@@ -306,7 +305,7 @@ src_unpack() {
}
src_prepare() {
- default
+ xdg_src_prepare
# sandbox violations on many systems, we don't need it. Bug #646406
sed -i \
@@ -566,14 +565,7 @@ src_install() {
pax-mark -m "${ED%/}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
}
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
+pkg_preinst() {
+ java-utils-2_pkg_preinst
+ xdg_pkg_preinst
}