summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2017-01-08 14:53:43 -0500
committerChris Reffett <creffett@gentoo.org>2017-01-08 15:03:54 -0500
commit604dbcbd3a89514dcb6c6b2f7bcb0914f8b1d80b (patch)
tree221031ec2adaeef66d686d7bce1ff46ccdeb5699 /app-office/projectlibre-bin
parentgnome-extra/cinnamon-screensaver: Add 3.2.6 (diff)
downloadgentoo-604dbcbd3a89514dcb6c6b2f7bcb0914f8b1d80b.tar.gz
gentoo-604dbcbd3a89514dcb6c6b2f7bcb0914f8b1d80b.tar.bz2
gentoo-604dbcbd3a89514dcb6c6b2f7bcb0914f8b1d80b.zip
app-office/projectlibre-bin: New package to supersede openproj
Gentoo-Bug: 436958 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-office/projectlibre-bin')
-rw-r--r--app-office/projectlibre-bin/Manifest1
-rw-r--r--app-office/projectlibre-bin/files/projectlibre.desktop12
-rw-r--r--app-office/projectlibre-bin/files/projectlibre.pngbin0 -> 7955 bytes
-rw-r--r--app-office/projectlibre-bin/metadata.xml11
-rw-r--r--app-office/projectlibre-bin/projectlibre-bin-1.6.2.ebuild51
5 files changed, 75 insertions, 0 deletions
diff --git a/app-office/projectlibre-bin/Manifest b/app-office/projectlibre-bin/Manifest
new file mode 100644
index 000000000000..297fc14773e0
--- /dev/null
+++ b/app-office/projectlibre-bin/Manifest
@@ -0,0 +1 @@
+DIST projectlibre-1.6.2.tar.gz 14735171 SHA256 72ea964533a2da0af0882acb91268647e7f5a99151b0abb8f3b84c6f26229fc4 SHA512 128319a37aeeb4603fd45433e3961805b0de30e5760394d5eef2de1910bff3815e600462aa3264fa64df55eb8568849895c9d673e5574badafcbc1df89e2c9e7 WHIRLPOOL 78124a7a2dd488b55938cd0e2465ab5212dd3cc9dfb673a408664667fe49458ac6cf8aa9b684832e51c1af18f7fdd48acd5fd967db70eb4ee5f9f3b70c615289
diff --git a/app-office/projectlibre-bin/files/projectlibre.desktop b/app-office/projectlibre-bin/files/projectlibre.desktop
new file mode 100644
index 000000000000..6087406b0533
--- /dev/null
+++ b/app-office/projectlibre-bin/files/projectlibre.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=ProjectLibre
+Comment=Project Management
+Comment[fr]=Gestion de projet
+Exec=projectlibre %F
+Icon=projectlibre
+Terminal=false
+Type=Application
+Categories=Office;ProjectManagement;
+MimeType=application/x-projectlibre;
+
diff --git a/app-office/projectlibre-bin/files/projectlibre.png b/app-office/projectlibre-bin/files/projectlibre.png
new file mode 100644
index 000000000000..a68aff0629ff
--- /dev/null
+++ b/app-office/projectlibre-bin/files/projectlibre.png
Binary files differ
diff --git a/app-office/projectlibre-bin/metadata.xml b/app-office/projectlibre-bin/metadata.xml
new file mode 100644
index 000000000000..5ae0c0c4e56f
--- /dev/null
+++ b/app-office/projectlibre-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>creffett@gentoo.org</email>
+ <name>Chris Reffett</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">projectlibre</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-office/projectlibre-bin/projectlibre-bin-1.6.2.ebuild b/app-office/projectlibre-bin/projectlibre-bin-1.6.2.ebuild
new file mode 100644
index 000000000000..1b063c2fc88f
--- /dev/null
+++ b/app-office/projectlibre-bin/projectlibre-bin-1.6.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+inherit eutils
+
+MY_PN=${PN/-bin}
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An open source desktop alternative to Microsoft Project"
+HOMEPAGE="http://www.projectlibre.org/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="CPAL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cp "${FILESDIR}"/${MY_PN}.{desktop,png} ./ || die
+ cd "${S}"
+ rm -rf license projectlibre.bat
+}
+
+src_prepare() {
+ eapply_user
+ sed -i \
+ -e "/^OPENPROJ_HOME0=/s:=.*:=/opt/${MY_PN}:" \
+ ${MY_PN}.sh || die
+}
+
+src_install() {
+ local d="/opt/${MY_PN}"
+ insinto ${d}
+ doins -r * || die
+ fperms a+rx ${d}/${MY_PN}.sh
+
+ dodir /opt/bin
+ dosym ../${MY_PN}/${MY_PN}.sh /opt/bin/${MY_PN} || die
+
+ newmenu ../${MY_PN}.desktop ${MY_PN}.desktop || die
+ newicon ../${MY_PN}.png ${MY_PN}.png || die
+}