summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-06 21:17:35 +0000
committerSam James <sam@gentoo.org>2021-11-06 21:17:35 +0000
commit0362c8a4b72e4fac0a0f8c8476a0e6426f44a0d4 (patch)
tree05b405012346711f88860cb65b26abd3a87af5f3 /app-office
parentmedia-gfx/inkscape: fix build with Poppler 21.11.0 (diff)
downloadgentoo-0362c8a4b72e4fac0a0f8c8476a0e6426f44a0d4.tar.gz
gentoo-0362c8a4b72e4fac0a0f8c8476a0e6426f44a0d4.tar.bz2
gentoo-0362c8a4b72e4fac0a0f8c8476a0e6426f44a0d4.zip
app-office/texstudio: add 4.0.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texstudio/Manifest1
-rw-r--r--app-office/texstudio/texstudio-4.0.4.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-office/texstudio/Manifest b/app-office/texstudio/Manifest
index 223983b7a0e6..a6c0d336d74a 100644
--- a/app-office/texstudio/Manifest
+++ b/app-office/texstudio/Manifest
@@ -3,3 +3,4 @@ DIST texstudio-3.1.2.tar.gz 83987451 BLAKE2B 0649a4f2a429d1d7a6134e154c338f623de
DIST texstudio-4.0.0.tar.gz 88426776 BLAKE2B 616ffaf35a4f2c5e5290517b38301c575b91251374ee96dc58560f40115ffd5e4e68830fe927283dcdf0f9c9b38815fe04a86a7e58e2dc7936b2b32e38bd6662 SHA512 9025e0709145ed9c352f9cfd748087b331fd2894c913d7b7707254050ea41d5df74077c8f94cc3fb19c4700d468d55e91895da1ea474759d83af499ef436cdbc
DIST texstudio-4.0.1.tar.gz 88469841 BLAKE2B ef1987fd3e733e9de57db5d8f2e25802f8eb86ad8a957f236283db41756c6e8cb133646d212d2d85d9c2ea9b53f2677f8ce76509d7e4634465859251a280c978 SHA512 cb993027950a525ac8cc5eac4ca95e0c9ffa712aab6f27d8c22b46e52d4edc3e05b2ba16efbf5d8c0e40d6ef75abcdd6dbd86ef59fd0f7b87ab4cbbd03f83b85
DIST texstudio-4.0.2.tar.gz 88557508 BLAKE2B 51c7b80f01e6e657b901d197bae01e4314446690d8169da823d2bc0be13a1918c248976f81ec64c1ce57dc523fd1b3a1aa01709cce3d56de207a69d42c9cb512 SHA512 a2579788cac0ddf1edc7be2040ea13bc7aece5596a91cd8361a4de8c7fafaa86c95ef34e40f4a0bdf3b5cfc52c951af737138ccd26dbf8ac730ec64f8a38cfd7
+DIST texstudio-4.0.4.tar.gz 88475885 BLAKE2B c9a90c2b3535e9baaf2e92da953b45d9d7127485c8b941b4146274ddf17e1fb6f212062fb514bf0f2708c4252dc7a9f25dad5b3d4a273165b143e7d3b996fc5f SHA512 1b31e05058a3ec4f82745dbd74f130ab8a40bca3740a845c0a3f06dc97467b25e08330cffb16e914ad9c7a2b97a744d8c63e552287b469a07bbe995dcd75eb82
diff --git a/app-office/texstudio/texstudio-4.0.4.ebuild b/app-office/texstudio/texstudio-4.0.4.ebuild
new file mode 100644
index 000000000000..27eded34899a
--- /dev/null
+++ b/app-office/texstudio/texstudio-4.0.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils xdg
+
+MY_PV="${PV/_/}"
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
+SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="video"
+
+DEPEND="
+ app-text/hunspell:=
+ app-text/poppler:=[qt5]
+ >=dev-libs/quazip-0.7.3-r1:0=
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsvg:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ video? ( >=media-libs/phonon-4.11.0 )
+"
+RDEPEND="
+ ${DEPEND}
+ app-text/ghostscript-gpl
+ app-text/psutils
+ media-libs/netpbm
+ virtual/latex-base
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.5-quazip1.patch" # TODO: upstream
+)
+
+src_prepare() {
+ xdg_src_prepare
+
+ # TODO: find hunspell quazip utilities/poppler-data qtsingleapplication -delete || die
+ rm -r src/quazip || die
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed -e "/qtsingleapplication.pri/s/.*/CONFIG += qtsingleapplication/" \
+ -i ${PN}.pro || die
+}
+
+src_configure() {
+ eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1 NO_TESTS=false
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+ newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
+ done
+
+ emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+}