summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall T. Vasquez <ran.dall@icloud.com>2022-07-11 11:09:55 -0700
committerSam James <sam@gentoo.org>2022-07-12 03:46:49 +0100
commit05307037bb3db5b678df6dfe3ed186fec4dffd32 (patch)
tree559aca3233d98fc37e5be53262353433d842cb22 /app-office
parentdev-cpp/range-v3: version 0.12.0 (diff)
downloadgentoo-05307037bb3db5b678df6dfe3ed186fec4dffd32.tar.gz
gentoo-05307037bb3db5b678df6dfe3ed186fec4dffd32.tar.bz2
gentoo-05307037bb3db5b678df6dfe3ed186fec4dffd32.zip
app-office/gtg: add ebuild for 0.6
This commit also bumps Python compatibility up to `3.10`. Signed-off-by: Randall T. Vasquez <ran.dall@icloud.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gtg/Manifest2
-rw-r--r--app-office/gtg/gtg-0.5.ebuild4
-rw-r--r--app-office/gtg/gtg-0.6.ebuild58
3 files changed, 61 insertions, 3 deletions
diff --git a/app-office/gtg/Manifest b/app-office/gtg/Manifest
index ead4f5170cf5..ab3e85e0c3c4 100644
--- a/app-office/gtg/Manifest
+++ b/app-office/gtg/Manifest
@@ -1,2 +1,2 @@
-DIST gtg-0.4.0.tar.xz 3744752 BLAKE2B fdeabe32135dea24ac6113a486650b66b5143aa745117029b03e26e1bb3f2e8629623b26efdae0c8217741a2b4964b5dc060f0e450c05c950e21ea360f3f3823 SHA512 f2677f6bbc0b6cb21b7882a2bd0342b4919581c12e4aa43c13b5dbc48740418c512a41619584d0d75bfa63ebc4a5460abfbc27360e1817c8832cbecf3c34a60e
DIST gtg-0.5.tar.gz 2229259 BLAKE2B e724cbd015a6f0b6fee62c52283b56244490efb7df4e57b2e30745f58fbc41442b008f5c81b53cfd001f04a92ff53a14e2117d6c12d0d5a35fe49158b5f736fa SHA512 631f5343301d7d72211398152fa081c0fa15154babc7ec900f13a39a2677d0edaf4fea534a83284207e8019926c9108dc1d8f25bdbeae85ef0665dfe1c7b768a
+DIST gtg-0.6.tar.gz 2361876 BLAKE2B 48f4d589b19181c4e5586254a3411fe2e25126d0f16b2d1294b8bff3f7a86aee7a34762781d9819760ce2e6b36ebded225a478a1bc86aa4c17217b165dae2802 SHA512 68a5229c17b85b87a9a134a08e5e86fbf24d28d6ce55e848c17eef650620d6f56172ee495cb113f4279b34c19127ae03981e2feec5a39dc51be49e387e458600
diff --git a/app-office/gtg/gtg-0.5.ebuild b/app-office/gtg/gtg-0.5.ebuild
index c3ae9ba1ab10..fae2baafad03 100644
--- a/app-office/gtg/gtg-0.5.ebuild
+++ b/app-office/gtg/gtg-0.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml(+)"
inherit meson python-single-r1 xdg
diff --git a/app-office/gtg/gtg-0.6.ebuild b/app-office/gtg/gtg-0.6.ebuild
new file mode 100644
index 000000000000..e55a20f164bf
--- /dev/null
+++ b/app-office/gtg/gtg-0.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Personal organizer for the GNOME desktop environment"
+HOMEPAGE="https://wiki.gnome.org/Apps/GTG/"
+SRC_URI="https://github.com/getting-things-gnome/gtg/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/liblarch-3.1.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ')
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ test? ( $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/cheetah3[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ')
+ || ( app-text/pdfjam >=app-text/texlive-core-2021 )
+ app-text/pdftk
+ dev-texlive/texlive-latex
+ )
+"
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"/usr/bin/gtg
+ python_optimize
+}
+
+src_test() {
+ sed -e "s|@VCS_TAG@|${PV}|" GTG/core/info.py.in > GTG/core/info.py || die
+ nosetests -v || die
+}