summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 12:28:52 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:10:57 +0100
commit05b8398c0b4125f5dff270ad320e9035bba9ae1b (patch)
treeb1a9f4c39085a618cebcf9da0c65e4c66a693cd7 /app-office
parentapp-office/libreoffice: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-05b8398c0b4125f5dff270ad320e9035bba9ae1b.tar.gz
gentoo-05b8398c0b4125f5dff270ad320e9035bba9ae1b.tar.bz2
gentoo-05b8398c0b4125f5dff270ad320e9035bba9ae1b.zip
app-office/moneyguru: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/moneyguru/moneyguru-2.13.1-r2.ebuild (renamed from app-office/moneyguru/moneyguru-2.13.1-r1.ebuild)8
-rw-r--r--app-office/moneyguru/moneyguru-3.0.1-r2.ebuild (renamed from app-office/moneyguru/moneyguru-3.0.1-r1.ebuild)8
2 files changed, 12 insertions, 4 deletions
diff --git a/app-office/moneyguru/moneyguru-2.13.1-r1.ebuild b/app-office/moneyguru/moneyguru-2.13.1-r2.ebuild
index 5e3aaab58e12..31987d2240e4 100644
--- a/app-office/moneyguru/moneyguru-2.13.1-r1.ebuild
+++ b/app-office/moneyguru/moneyguru-2.13.1-r2.ebuild
@@ -21,11 +21,15 @@ REQUIRED_USE=${PYTHON_REQUIRED_USE}
RDEPEND="${PYTHON_DEPS}
dev-db/sqlite:3
dev-libs/glib:2
- dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets,printsupport]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,widgets,printsupport]
+ ')
dev-qt/qttranslations"
DEPEND="${RDEPEND}
test? (
- <dev-python/pytest-4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ <dev-python/pytest-4[${PYTHON_MULTI_USEDEP}]
+ ')
dev-util/cunit
)"
diff --git a/app-office/moneyguru/moneyguru-3.0.1-r1.ebuild b/app-office/moneyguru/moneyguru-3.0.1-r2.ebuild
index db78b348715e..ba927b91e60b 100644
--- a/app-office/moneyguru/moneyguru-3.0.1-r1.ebuild
+++ b/app-office/moneyguru/moneyguru-3.0.1-r2.ebuild
@@ -21,11 +21,15 @@ REQUIRED_USE=${PYTHON_REQUIRED_USE}
RDEPEND="${PYTHON_DEPS}
dev-db/sqlite:3
dev-libs/glib:2
- dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets,printsupport]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,widgets,printsupport]
+ ')
dev-qt/qttranslations"
DEPEND="${RDEPEND}
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ ')
dev-util/cunit
)"