summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-08-28 21:41:52 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-08-28 21:41:52 +0100
commit09ba952291d08d85ba05399997457c5d5a501538 (patch)
treeb1edaf79d23fa50778c0bc5f0f7c2feb9f099850 /app-office
parentdev-util/re2c: fix -V option handling, bug #664752 (diff)
downloadgentoo-09ba952291d08d85ba05399997457c5d5a501538.tar.gz
gentoo-09ba952291d08d85ba05399997457c5d5a501538.tar.bz2
gentoo-09ba952291d08d85ba05399997457c5d5a501538.zip
app-office/orage: Fix building with libical 3
Thanks to Stefan Seyfried for the patch. It has been sent upstream. Closes: https://bugs.gentoo.org/657542 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'app-office')
-rw-r--r--app-office/orage/files/0001-fix-build-with-libical-version-3.patch76
-rw-r--r--app-office/orage/orage-4.12.1-r1.ebuild4
2 files changed, 80 insertions, 0 deletions
diff --git a/app-office/orage/files/0001-fix-build-with-libical-version-3.patch b/app-office/orage/files/0001-fix-build-with-libical-version-3.patch
new file mode 100644
index 000000000000..ad57fd3cbc91
--- /dev/null
+++ b/app-office/orage/files/0001-fix-build-with-libical-version-3.patch
@@ -0,0 +1,76 @@
+From 58e4bb4d3b982876dec33d55003d591559439598 Mon Sep 17 00:00:00 2001
+From: Stefan Seyfried <seife+dev@b1-systems.com>
+Date: Sat, 3 Mar 2018 20:25:24 +0100
+Subject: [PATCH] fix build with libical version 3
+
+---
+ src/ical-code.c | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/src/ical-code.c b/src/ical-code.c
+index d5831404..c40042c3 100644
+--- a/src/ical-code.c
++++ b/src/ical-code.c
+@@ -2579,7 +2579,9 @@ static struct icaltimetype count_first_alarm_time(xfical_period per
+ * when counting alarm time. */
+ if (rel == ICAL_RELATED_START) {
+ per.stime.is_date = 0;
++#if ICAL_MAJOR_VERSION < 3
+ per.stime.is_utc = 1;
++#endif
+ per.stime.is_daylight = 0;
+ per.stime.zone = utc_icaltimezone;
+ per.stime.hour = 0;
+@@ -2588,7 +2590,9 @@ static struct icaltimetype count_first_alarm_time(xfical_period per
+ }
+ else {
+ per.etime.is_date = 0;
++#if ICAL_MAJOR_VERSION < 3
+ per.etime.is_utc = 1;
++#endif
+ per.etime.is_daylight = 0;
+ per.etime.zone = utc_icaltimezone;
+ per.etime.hour = 0;
+@@ -2613,7 +2617,9 @@ static struct icaltimetype count_next_alarm_time(struct icaltimetype start_time
+ /* HACK: convert to UTC time so that we can use time arithmetic
+ * when counting alarm time. */
+ start_time.is_date = 0;
++#if ICAL_MAJOR_VERSION < 3
+ start_time.is_utc = 1;
++#endif
+ start_time.is_daylight = 0;
+ start_time.zone = utc_icaltimezone;
+ start_time.hour = 0;
+@@ -2768,7 +2774,9 @@ static alarm_struct *process_alarm_trigger(icalcomponent *c
+ */
+ if (icaltime_is_date(per.stime)) {
+ if (local_icaltimezone != utc_icaltimezone) {
++#if ICAL_MAJOR_VERSION < 3
+ next_alarm_time.is_utc = 0;
++#endif
+ next_alarm_time.is_daylight = 0;
+ next_alarm_time.zone = local_icaltimezone;
+ }
+@@ -2850,7 +2858,9 @@ orage_message(120, P_N "Alarm rec loop next_start:%s next_alarm:%s per.stime:%s"
+ */
+ if (icaltime_is_date(per.stime)) {
+ if (local_icaltimezone != utc_icaltimezone) {
++#if ICAL_MAJOR_VERSION < 3
+ next_alarm_time.is_utc = 0;
++#endif
+ next_alarm_time.is_daylight = 0;
+ next_alarm_time.zone = local_icaltimezone;
+ }
+@@ -2944,7 +2954,9 @@ orage_message(120, P_N "*****After loop Alarm %s %s", icaltime_as_ical_string(ne
+ */
+ if (icaltime_is_date(per.stime)) {
+ if (local_icaltimezone != utc_icaltimezone) {
++#if ICAL_MAJOR_VERSION < 3
+ next_alarm_time.is_utc = 0;
++#endif
+ next_alarm_time.is_daylight = 0;
+ next_alarm_time.zone = local_icaltimezone;
+ }
+--
+2.16.2
+
diff --git a/app-office/orage/orage-4.12.1-r1.ebuild b/app-office/orage/orage-4.12.1-r1.ebuild
index afbcd0af7e23..9dcf63abcbc6 100644
--- a/app-office/orage/orage-4.12.1-r1.ebuild
+++ b/app-office/orage/orage-4.12.1-r1.ebuild
@@ -27,6 +27,10 @@ DEPEND="${RDEPEND}
>=sys-devel/libtool-2.2.6
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/0001-fix-build-with-libical-version-3.patch
+)
+
src_configure() {
local myconf=(
--libexecdir="${EPREFIX}/usr/$(get_libdir)"