summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-10 20:26:49 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-10 20:53:23 -0500
commit2347c6fe886c6b89d93ffac0faf375a613c372b1 (patch)
tree9ac1ed0abe7e86cbfe62a110a23675af21655134 /app-office
parentnet-libs/mbedtls: version bump to 2.1.3 (diff)
downloadgentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.gz
gentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.bz2
gentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.zip
avoid using ${var^} and ${var,} as they do not work in bash-3.2
Once these upgrade to EAPI=6, they can use these case modification features, so leave a reminder note in there.
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calligra/calligra-2.9.6.ebuild5
-rw-r--r--app-office/calligra/calligra-2.9.7.ebuild5
-rw-r--r--app-office/calligra/calligra-9999.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/app-office/calligra/calligra-2.9.6.ebuild b/app-office/calligra/calligra-2.9.6.ebuild
index 4031e5beaaa6..ea5198b88d15 100644
--- a/app-office/calligra/calligra-2.9.6.ebuild
+++ b/app-office/calligra/calligra-2.9.6.ebuild
@@ -160,7 +160,10 @@ src_configure() {
# applications
for cal_ft in ${CAL_FTS}; do
- use calligra_features_${cal_ft} && myproducts+=( ${cal_ft^^} )
+ # Switch to ^^ when we switch to EAPI=6.
+ #local prod=${cal_ft^^}
+ local prod=$(tr '[:lower:]' '[:upper:]' <<<"${cal_ft}")
+ use calligra_features_${cal_ft} && myproducts+=( "${prod}" )
done
local mycmakeargs=( -DPRODUCTSET="${myproducts[*]}" )
diff --git a/app-office/calligra/calligra-2.9.7.ebuild b/app-office/calligra/calligra-2.9.7.ebuild
index 97cea479c13f..0822a6951c58 100644
--- a/app-office/calligra/calligra-2.9.7.ebuild
+++ b/app-office/calligra/calligra-2.9.7.ebuild
@@ -157,7 +157,10 @@ src_configure() {
# applications
for cal_ft in ${CAL_FTS}; do
- use calligra_features_${cal_ft} && myproducts+=( ${cal_ft^^} )
+ # Switch to ^^ when we switch to EAPI=6.
+ #local prod=${cal_ft^^}
+ local prod=$(tr '[:lower:]' '[:upper:]' <<<"${cal_ft}")
+ use calligra_features_${cal_ft} && myproducts+=( "${prod}" )
done
local mycmakeargs=( -DPRODUCTSET="${myproducts[*]}" )
diff --git a/app-office/calligra/calligra-9999.ebuild b/app-office/calligra/calligra-9999.ebuild
index 97cea479c13f..0822a6951c58 100644
--- a/app-office/calligra/calligra-9999.ebuild
+++ b/app-office/calligra/calligra-9999.ebuild
@@ -157,7 +157,10 @@ src_configure() {
# applications
for cal_ft in ${CAL_FTS}; do
- use calligra_features_${cal_ft} && myproducts+=( ${cal_ft^^} )
+ # Switch to ^^ when we switch to EAPI=6.
+ #local prod=${cal_ft^^}
+ local prod=$(tr '[:lower:]' '[:upper:]' <<<"${cal_ft}")
+ use calligra_features_${cal_ft} && myproducts+=( "${prod}" )
done
local mycmakeargs=( -DPRODUCTSET="${myproducts[*]}" )