summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2015-11-10 17:57:40 -0600
committerErik Mackdanz <stasibear@gentoo.org>2015-11-10 17:57:40 -0600
commit38e23b12679693b3ac1f44aa40dde39b5c9f2499 (patch)
tree57b5183c19f4d67a1e4305c737bad61264991ed7 /app-office
parentAdds python3_5 to PYTHON_COMPAT (diff)
downloadgentoo-38e23b12679693b3ac1f44aa40dde39b5c9f2499.tar.gz
gentoo-38e23b12679693b3ac1f44aa40dde39b5c9f2499.tar.bz2
gentoo-38e23b12679693b3ac1f44aa40dde39b5c9f2499.zip
app-office/ledger: revbump to 3.1-r1
Adds IUSE="doc emacs". Closing bug 564226 Package-Manager: portage-2.2.24
Diffstat (limited to 'app-office')
-rw-r--r--app-office/ledger/files/50ledger-gentoo-3.1.el5
-rw-r--r--app-office/ledger/ledger-3.1-r1.ebuild71
2 files changed, 76 insertions, 0 deletions
diff --git a/app-office/ledger/files/50ledger-gentoo-3.1.el b/app-office/ledger/files/50ledger-gentoo-3.1.el
new file mode 100644
index 000000000000..1c2c5bde2f8b
--- /dev/null
+++ b/app-office/ledger/files/50ledger-gentoo-3.1.el
@@ -0,0 +1,5 @@
+
+;;; app-office/ledger site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ledger-mode "ledger-mode" "A mode for editing ledger data files." t)
diff --git a/app-office/ledger/ledger-3.1-r1.ebuild b/app-office/ledger/ledger-3.1-r1.ebuild
new file mode 100644
index 000000000000..c1714fd590b2
--- /dev/null
+++ b/app-office/ledger/ledger-3.1-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils elisp-common
+
+DESCRIPTION="A double-entry accounting system with a command-line reporting interface"
+HOMEPAGE="http://ledger-cli.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc emacs"
+
+SITEFILE=50${PN}-gentoo-${PV}.el
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/gmp:0
+ dev-libs/mpfr:0
+ emacs? ( virtual/emacs )
+"
+DEPEND="${RDEPEND}
+ dev-libs/utfcpp
+ doc? ( sys-apps/texinfo )
+"
+
+DOCS=(README-1ST README.md)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build emacs EMACSLISP)
+ $(cmake-utils_use_build doc DOCS)
+ $(cmake-utils_use_build doc WEB_DOCS)
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && cmake-utils_src_make doc
+}
+
+src_install() {
+ enable_cmake-utils_src_install
+
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ einfo
+ einfo "Since version 3, vim support is released separately."
+ einfo "See https://github.com/ledger/vim-ledger"
+ einfo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
+
+# rainy day TODO:
+# - IUSE python
+# - IUSE test