summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Bosch <stephen.bosch@gmail.com>2015-11-26 12:26:00 +0100
committerStephen Bosch <stephen.bosch@gmail.com>2015-11-26 12:26:00 +0100
commit428abb3121094fd558a371b66eb8d68ae7cd38b0 (patch)
treec637878819731e2e95cdbacc86cb179ccdb1c137 /app-office
parentnet-misc/curl: amd64 stable wrt bug #566864 (diff)
downloadgentoo-428abb3121094fd558a371b66eb8d68ae7cd38b0.tar.gz
gentoo-428abb3121094fd558a371b66eb8d68ae7cd38b0.tar.bz2
gentoo-428abb3121094fd558a371b66eb8d68ae7cd38b0.zip
app-office/texmaker: version bump to 4.5 #566790
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texmaker/Manifest1
-rw-r--r--app-office/texmaker/files/texmaker-4.5-modern-styles.patch16
-rw-r--r--app-office/texmaker/files/texmaker-4.5-unbundle.patch93
-rw-r--r--app-office/texmaker/texmaker-4.5.ebuild99
4 files changed, 209 insertions, 0 deletions
diff --git a/app-office/texmaker/Manifest b/app-office/texmaker/Manifest
index f9de17820083..9d351b717fe7 100644
--- a/app-office/texmaker/Manifest
+++ b/app-office/texmaker/Manifest
@@ -1 +1,2 @@
DIST texmaker-4.4.1.tar.bz2 11274997 SHA256 80939493ffb6c92f47c47109dff6de4c91259244247e90ddfb1bb6153559b4b4 SHA512 a165b7757f2170d42f3d48d644cb351efd4d308b1a0601105952c3253084ae4a3d0bbfb7915207ff60d0ba7036283c6c8305a901d7ac8aab4e79c1bb78f68ddd WHIRLPOOL 3b00a894a194659d64ea8058ca1f0d04a68904f4eb638121f935ab83583b83c57bae3d1abb8d1e0541bed4bbaa44336e9733e8de3d346098dafae319437909f2
+DIST texmaker-4.5.tar.bz2 11287724 SHA256 2ce9966e410bf878649d1c756e3dc2a077e55e1eaa9f4beb10aa7224cd94d614 SHA512 623ae1496f11e5cd1328b997dbb29ec7188d6c1b256b6370c6fdd4fcda4bfc4b301d29cfa3b2ce529391b8f9913ea4678a6895abfb4fa6f9820e7177c676ab11 WHIRLPOOL 0fb00957cb6fe2f3181ac6a6ad917fd60d90ca05bcbaa14da62045ac6c5d78126d9abeb1429bd1fe48a25416d95a1a52c53f83cad91cb0540fcd043a9ea63045
diff --git a/app-office/texmaker/files/texmaker-4.5-modern-styles.patch b/app-office/texmaker/files/texmaker-4.5-modern-styles.patch
new file mode 100644
index 000000000000..73c3b92f761b
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-4.5-modern-styles.patch
@@ -0,0 +1,16 @@
+--- a/texmaker.cpp 2014-11-26 09:06:56.000000000 -0300
++++ b/texmaker.cpp 2015-06-19 20:49:58.801377000 -0300
+@@ -4451,7 +4451,12 @@
+ #if (QT_VERSION >= QT_VERSION_CHECK(5, 0, 0))
+ if (modern_style)
+ {
+-qApp->setStyle(new ManhattanStyle(QLatin1String("fusion")));
++ if(desktop_env == 1){
++ if (styles.contains("GTK+")) qApp->setStyle(new ManhattanStyle(QLatin1String("gtkstyle")));
++ else if (styles.contains("Windows")) qApp->setStyle(new ManhattanStyle(QLatin1String("windows")));
++ else qApp->setStyle(new ManhattanStyle(QLatin1String("fusion")));
++ }
++ else qApp->setStyle(new ManhattanStyle(QLatin1String("fusion")));
+ }
+ // else
+ // {
diff --git a/app-office/texmaker/files/texmaker-4.5-unbundle.patch b/app-office/texmaker/files/texmaker-4.5-unbundle.patch
new file mode 100644
index 000000000000..607b2c8b7e41
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-4.5-unbundle.patch
@@ -0,0 +1,93 @@
+diff --git a/configdialog.cpp b/configdialog.cpp
+index dddb11e..9a1aee7 100644
+--- a/configdialog.cpp
++++ b/configdialog.cpp
+@@ -222,7 +222,7 @@ void ConfigDialog::browseAspell()
+ QDir spelldir(QCoreApplication::applicationDirPath());
+ #else
+ #ifdef DEBIAN_SPELLDIR
+-QDir spelldir(PREFIX"/share/myspell/dicts");
++QDir spelldir(PREFIX"/share/myspell");
+ #else
+ QDir spelldir(PREFIX"/share/texmaker");
+ #endif
+diff --git a/texmaker.cpp b/texmaker.cpp
+index b8a2143..a8bcd46 100644
+--- a/texmaker.cpp
++++ b/texmaker.cpp
+@@ -2787,7 +2787,7 @@ if (hasDecodingError)
+ QString dicDir=QCoreApplication::applicationDirPath() + "/";
+ #else
+ #ifdef DEBIAN_SPELLDIR
+-QString dicDir=PREFIX"/share/myspell/dicts/";
++QString dicDir=PREFIX"/share/myspell/";
+ #else
+ QString dicDir=PREFIX"/share/texmaker/";
+ #endif
+diff --git a/texmaker.pro b/texmaker.pro
+index 7e9b706..909eb62 100644
+--- a/texmaker.pro
++++ b/texmaker.pro
+@@ -98,29 +98,6 @@ HEADERS += texmaker.h \
+ unicodeview.h \
+ quickbeamerdialog.h \
+ svnhelper.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell \
+- hunspell/filemgr.hxx \
+- hunspell/hunzip.hxx \
+- hunspell/replist.hxx \
+- hunspell/w_char.hxx \
+- singleapp/qtlocalpeer.h \
+- singleapp/qtlockedfile.h \
+- singleapp/qtsingleapplication.h \
+- singleapp/qtsinglecoreapplication.h \
+ encodingprober/CharDistribution.h \
+ encodingprober/ChineseGroupProber.h \
+ encodingprober/ctype_test_p.h \
+@@ -210,22 +187,6 @@ SOURCES += main.cpp \
+ unicodeview.cpp \
+ quickbeamerdialog.cpp \
+ svnhelper.cpp \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx \
+- hunspell/filemgr.cxx \
+- hunspell/replist.cxx \
+- hunspell/hunzip.cxx \
+- singleapp/qtlocalpeer.cpp \
+- singleapp/qtlockedfile.cpp \
+- singleapp/qtsingleapplication.cpp \
+- singleapp/qtsinglecoreapplication.cpp \
+ encodingprober/CharDistribution.cpp \
+ encodingprober/ChineseGroupProber.cpp \
+ encodingprober/JapaneseGroupProber.cpp \
+@@ -336,8 +297,7 @@ icon.path = $${ICONDIR}
+
+ INSTALLS = target
+ HEADERS += x11fontdialog.h
+-SOURCES += x11fontdialog.cpp \
+- singleapp/qtlockedfile_unix.cpp
++SOURCES += x11fontdialog.cpp
+ FORMS += x11fontdialog.ui
+
+ utilities.files = doc/doc1.png \
diff --git a/app-office/texmaker/texmaker-4.5.ebuild b/app-office/texmaker/texmaker-4.5.ebuild
new file mode 100644
index 000000000000..63debcea6930
--- /dev/null
+++ b/app-office/texmaker/texmaker-4.5.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qmake-utils readme.gentoo
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+qt4 qt5"
+
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4?,qt5?]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ dev-qt/qtsingleapplication[X,qt4?,qt5?]
+ qt4? (
+ dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ dev-qt/qtscript:4
+ dev-qt/qtwebkit:4
+ )
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtscript:5
+ dev-qt/qtwebkit:5[printsupport]
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm
+ qt4? ( app-i18n/ibus-qt )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-unbundle.patch
+ "${FILESDIR}"/${P}-modern-styles.patch
+ )
+
+DOCS=( utilities/AUTHORS utilities/CHANGELOG.txt )
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ find singleapp hunspell -delete || die
+
+ epatch "${PATCHES[@]}"
+
+ cat >> ${PN}.pro <<- EOF
+ exists(texmakerx_my.pri):include(texmakerx_my.pri)
+ EOF
+
+ cp "${FILESDIR}"/texmakerx_my.pri . || die
+
+ sed \
+ -e '/^#include/s:hunspell/::g' \
+ -e '/^#include/s:singleapp/::g' \
+ -i *.cpp *.h || die
+
+ DOC_CONTENTS="A user manual with many screenshots is available at:
+ ${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}
+
+src_configure() {
+ local myeqmakeargs=(
+ ${PN}.pro
+ PREFIX="${EPREFIX}/usr"
+ DESKTOPDIR="${EPREFIX}/usr/share/applications"
+ ICONDIR="${EPREFIX}/usr/share/pixmaps"
+ )
+ if use qt4; then
+ eqmake4 ${myeqmakeargs[@]}
+ else
+ eqmake5 ${myeqmakeargs[@]}
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+ readme.gentoo_create_doc
+}