summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfe İzbudak <efe.izbudak@metu.edu.tr>2022-06-29 17:33:57 +0300
committerSam James <sam@gentoo.org>2022-08-29 23:37:50 +0100
commit451e97732fc14733aa35aa236b793219b4eee9cb (patch)
treeb4f4e37cd33bd529eca71b1ca2876bc3d45f2c4f /app-office
parentdev-libs/libxlsxwriter: new package, add 1.1.4 (diff)
downloadgentoo-451e97732fc14733aa35aa236b793219b4eee9cb.tar.gz
gentoo-451e97732fc14733aa35aa236b793219b4eee9cb.tar.bz2
gentoo-451e97732fc14733aa35aa236b793219b4eee9cb.zip
app-office/sc-im: new package, add 0.8.2
Closes: https://bugs.gentoo.org/661516 Signed-off-by: Efe İzbudak <efe.izbudak@metu.edu.tr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/sc-im/Manifest1
-rw-r--r--app-office/sc-im/metadata.xml24
-rw-r--r--app-office/sc-im/sc-im-0.8.2.ebuild141
3 files changed, 166 insertions, 0 deletions
diff --git a/app-office/sc-im/Manifest b/app-office/sc-im/Manifest
new file mode 100644
index 000000000000..a085c5e62cde
--- /dev/null
+++ b/app-office/sc-im/Manifest
@@ -0,0 +1 @@
+DIST sc-im-0.8.2.tar.gz 1619617 BLAKE2B 1957b79749012b5e8b24e26f3cde63c84bf971d2183791f986c98ec823a9ab74bf8a126dcdb2a58920af07e068520ebd7efe9c9394235c5a58670f120495e980 SHA512 ae02fd31eb7254208de26802ed6d8b21d77ce2d6997f4a2de5bd2f0a002c763f67f53e6c8e49d66ded096ecd8bf50b1117015e9a0356eaf11c3caef22cf4552c
diff --git a/app-office/sc-im/metadata.xml b/app-office/sc-im/metadata.xml
new file mode 100644
index 000000000000..8f4ac17a19b5
--- /dev/null
+++ b/app-office/sc-im/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>efe.izbudak@metu.edu.tr</email>
+ <name>Efe İzbudak</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="plots">Add <pkg>sci-visualization/gnuplot</pkg> for plotting support</flag>
+ <flag name="xls">Add xls support</flag>
+ <flag name="xlsx">Add xlsx support</flag>
+ <flag name="ods">Add ods import support</flag>
+ <flag name="X">Use <pkg>x11-misc/xclip</pkg> for clipboard copy/paste</flag>
+ <flag name="tmux">Use <pkg>app-misc/tmux</pkg> for clipboard copy/paste</flag>
+ <flag name="wayland">Use <pkg>gui-apps/wl-clipboard</pkg> for clipboard copy/paste</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">andmarti1424/sc-im</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-office/sc-im/sc-im-0.8.2.ebuild b/app-office/sc-im/sc-im-0.8.2.ebuild
new file mode 100644
index 000000000000..bed8ce296550
--- /dev/null
+++ b/app-office/sc-im/sc-im-0.8.2.ebuild
@@ -0,0 +1,141 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 luajit )
+
+inherit lua-single toolchain-funcs flag-o-matic
+
+DESCRIPTION="Spreadsheet Calculator Improvised -- An ncurses spreadsheet program for terminal"
+HOMEPAGE="https://github.com/andmarti1424/sc-im"
+SRC_URI="https://github.com/andmarti1424/sc-im/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X plots wayland xls xlsx lua ods tmux"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+DEPEND="
+ sys-libs/ncurses:=
+
+ lua? (
+ ${LUA_DEPS}
+ )
+ ods? (
+ dev-libs/libxml2
+ dev-libs/libzip
+ )
+ plots? ( sci-visualization/gnuplot )
+ tmux? ( app-misc/tmux )
+ wayland? ( gui-apps/wl-clipboard )
+ X? ( x11-misc/xclip )
+ xls? (
+ dev-libs/libxls
+ )
+ xlsx? (
+ dev-libs/libxlsxwriter
+ dev-libs/libxml2
+ dev-libs/libzip
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ CONFLICTING=$(usex tmux "tmux " "")$(usex wayland "wayland " "")$(usex X "X" "")
+ if ( use tmux && ( use wayland || use X ) ) ; then
+ elog "Conflicting flags for clipboard support are set: ${CONFLICTING}"
+ elog "tmux support has been preferred."
+ elif ( use wayland && use X ) ; then
+ elog "Conflicting flags for clipboard support are set: ${CONFLICTING}"
+ elog "Wayland support has been preferred."
+ fi
+
+ # Run lua setup
+ lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Clean Makefile from all sorts of flag / lib setting
+ sed -i -e '/CFLAGS +=\|LDLIBS +=/d' Makefile \
+ || die "sed fix failed. Uh-oh..."
+ # Also clean the now useless comments and logic
+ sed -i -e '/#\|if\|else/d' Makefile \
+ || die "sed fix failed. Uh-oh..."
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ LDLIBS="-lm"
+
+ # default flags that dont need optional dependencies
+ append-cflags -Wall -g \
+ -DNCURSES \
+ -D_XOPEN_SOURCE_EXTENDED -D_GNU_SOURCE \
+ '-DSNAME=\"sc-im\"' \
+ '-DHELP_PATH=\"/usr/share/sc-im\"' \
+ '-DLIBDIR=\"/usr/share/doc/sc-im\"' \
+ '-DDFLT_PAGER=\"less\"' \
+ '-DDFLT_EDITOR=\"vim\"' \
+ -DUSECOLORS \
+ '-DHISTORY_FILE=\"sc-iminfo\"' \
+ '-DHISTORY_DIR=\".cache\"' \
+ '-DCONFIG_FILE=\"scimrc\"' \
+ '-DCONFIG_DIR=\".config/sc-im\"' \
+ '-DINS_HISTORY_FILE=\"sc-iminfo\"' \
+ -DUNDO \
+ -DMAXROWS=65536 \
+ -DUSELOCALE \
+ -DMOUSE \
+ '-DDEFAULT_OPEN_FILE_UNDER_CURSOR_CMD=\""scopen"\"' \
+ -DAUTOBACKUP \
+ -DHAVE_PTHREAD
+
+ # setting default clipboard commands
+ if use tmux ; then
+ append-cflags '-DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""tmux load-buffer"\"'
+ append-cflags '-DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""tmux show-buffer"\"'
+ elif use wayland ; then
+ append-cflags '-DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""wl-copy <"\"'
+ append-cflags '-DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""wl-paste"\"'
+ elif use X ; then
+ append-cflags '-DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""xclip -i -selection clipboard <"\"'
+ append-cflags '-DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""xclip -o -selection clipboard"\"'
+ fi
+
+ # optional feature dependency
+ use plots && append-cflags -DGNUPLOT
+ if use xls; then
+ append-cflags -DXLS $(${PKG_CONFIG} --cflags libxls)
+ LDLIBS+=" $(${PKG_CONFIG} --libs libxls)"
+ fi
+ if use xlsx || use ods ; then
+ append-cflags -DODS -DXLSX $(${PKG_CONFIG} --cflags libxml-2.0 libzip)
+ LDLIBS+=" -DODS -DXLSX $(${PKG_CONFIG} --libs libxml-2.0 libzip)"
+ fi
+ if use xlsx ; then
+ append-cflags -DXLSX_EXPORT $(${PKG_CONFIG} --cflags xlsxwriter)
+ LDLIBS+=" -DXLSX_EXPORT $(${PKG_CONFIG} --libs xlsxwriter)"
+ fi
+ if use lua ; then
+ append-cflags -DXLUA $(${PKG_CONFIG} --cflags lua)
+ LDLIBS+=" -DXLUA $(${PKG_CONFIG} --libs lua) -rdynamic"
+ fi
+ append-cflags $(${PKG_CONFIG} --cflags ncursesw) || append-cflags $(${PKG_CONFIG} --cflags ncurses)
+ LDLIBS+=" $(${PKG_CONFIG} --libs ncursesw)" || LDLIBS+=" $(${PKG_CONFIG} --libs ncurses)"
+}
+
+src_compile() {
+ emake LDLIBS="${LDLIBS}" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" install
+ einstalldocs
+}