summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-17 04:50:44 +0000
committerSam James <sam@gentoo.org>2020-12-17 04:52:59 +0000
commit5ce479f9aac6988ec5d76ce28499e767a97069ce (patch)
tree629c84b07f36ae952b01066656ecb1c1a1798b6e /app-office
parentmedia-libs/vulkan-loader: Fix pkgconfig (diff)
downloadgentoo-5ce479f9aac6988ec5d76ce28499e767a97069ce.tar.gz
gentoo-5ce479f9aac6988ec5d76ce28499e767a97069ce.tar.bz2
gentoo-5ce479f9aac6988ec5d76ce28499e767a97069ce.zip
app-office/texstudio: fix 3.0.1 tarball
The previous version was still using the alpha but calling it 3.0.0 and then 3.0.1. Closes: https://bugs.gentoo.org/740220 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texstudio/Manifest2
-rw-r--r--app-office/texstudio/texstudio-3.0.1-r1.ebuild (renamed from app-office/texstudio/texstudio-3.0.1.ebuild)22
2 files changed, 7 insertions, 17 deletions
diff --git a/app-office/texstudio/Manifest b/app-office/texstudio/Manifest
index f3d268f8d483..6bd01f7372e6 100644
--- a/app-office/texstudio/Manifest
+++ b/app-office/texstudio/Manifest
@@ -1,2 +1,2 @@
DIST texstudio-3.0.0_pre20200601.tar.gz 35982392 BLAKE2B 1eed56fe21aac141df41f251621a902a20153b0eaafc995b56fa8c3fbcc213685710e45202fbb90a071a0efac591c86588d4c5fe3727e603e0a58e149ed6864e SHA512 d922f576055fc345e7e0125074c6dbb473c6fb95aa06ae1ffc15f3b89fbdc7c5a44a13d4a32b770bef10c7bae7211a4bf3a269996eda1b3a0c8fd1ed8f3c4bb1
-DIST texstudio-3.0.1.tar.gz 35982392 BLAKE2B 1eed56fe21aac141df41f251621a902a20153b0eaafc995b56fa8c3fbcc213685710e45202fbb90a071a0efac591c86588d4c5fe3727e603e0a58e149ed6864e SHA512 d922f576055fc345e7e0125074c6dbb473c6fb95aa06ae1ffc15f3b89fbdc7c5a44a13d4a32b770bef10c7bae7211a4bf3a269996eda1b3a0c8fd1ed8f3c4bb1
+DIST texstudio-3.0.1-r1.tar.gz 36144393 BLAKE2B 63dad681a56ce60a90c44ab71930e8a14a7f335eb7d40f906aab2f5ca10375f768bafc3ae9023574b04c2b5196bc495ef47fb5fc9d4f6438da0a747ebd857972 SHA512 aba57d9f45af259131d3ab47463a30bec24d8fa5b30a9c574308b8a7d6c1117acb1553df20ebe5855281510f82c4d55700a0db0dffeee1b69f2afec234e18b93
diff --git a/app-office/texstudio/texstudio-3.0.1.ebuild b/app-office/texstudio/texstudio-3.0.1-r1.ebuild
index 549dc6356a4c..4b285ee4a888 100644
--- a/app-office/texstudio/texstudio-3.0.1.ebuild
+++ b/app-office/texstudio/texstudio-3.0.1-r1.ebuild
@@ -3,13 +3,15 @@
EAPI=7
-inherit prefix qmake-utils xdg-utils desktop
-
-MY_PV="3.0.0alpha6"
+inherit desktop prefix qmake-utils xdg
+# NOTE: Drop -r1 from SRC_URI on bump!
+# #740220
+MY_PV="${PV/_/}"
DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
-SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}-r1.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
LICENSE="GPL-2"
SLOT="0"
@@ -45,8 +47,6 @@ DEPEND="${COMMON_DEPEND}"
BDEPEND="virtual/pkgconfig"
-S=${WORKDIR}/${PN}-${MY_PV}
-
src_prepare() {
default
@@ -73,13 +73,3 @@ src_install() {
done
emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}