summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-11-11 14:02:59 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-11-11 14:04:36 +0100
commit6f770d63013f1e530faccfa7286168d273010d30 (patch)
treeef893884b8e41e92e85bb94b93add7eb6e890c85 /app-office
parentapp-office/gnucash: drop obsolete workaround for guile-config (diff)
downloadgentoo-6f770d63013f1e530faccfa7286168d273010d30.tar.gz
gentoo-6f770d63013f1e530faccfa7286168d273010d30.tar.bz2
gentoo-6f770d63013f1e530faccfa7286168d273010d30.zip
app-office/gnucash: remove guile automagic detection
This problem only affects users trying out lisp overlay or masked ebuilds in gentoo-x86 but it gets old. gnucash builds fine with guile-2.0 but we have no scheme herd to push it forward currently.
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/files/gnucash-2.6.9-automagic-guile.patch88
-rw-r--r--app-office/gnucash/gnucash-2.6.9.ebuild4
2 files changed, 92 insertions, 0 deletions
diff --git a/app-office/gnucash/files/gnucash-2.6.9-automagic-guile.patch b/app-office/gnucash/files/gnucash-2.6.9-automagic-guile.patch
new file mode 100644
index 000000000000..a871233ecd70
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-2.6.9-automagic-guile.patch
@@ -0,0 +1,88 @@
+From a42d0a1d9e3311a5e2356676fef7843f1726d343 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Wed, 11 Nov 2015 13:35:46 +0100
+Subject: [PATCH] Make guile support selectable
+
+---
+ configure.ac | 55 +++++++++++++++++++++++++++++++++++++------------------
+ 1 file changed, 37 insertions(+), 18 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 48ab828..ce7ba74 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -538,26 +538,45 @@ AC_CHECK_FUNCS(gethostid link)
+ ### --------------------------------------------------------------------------
+ ### Guile version checks
+
++GUILE_EFFECTIVE_VERSION=0
+ # - check minimum version
+ # - determine GUILE_CFLAGS and GUILE_LIBS
+-gnc_have_guile_2=no
+-gnc_have_guile_www=no
+-PKG_CHECK_MODULES(GUILE,
+- [guile-2.0 >= 2.0.0],
+- [gnc_have_guile_2=yes
+- GUILE_EFFECTIVE_VERSION=2.0
+- AC_PATH_PROG([GUILD], guild)],
+- [PKG_CHECK_MODULES(GUILE,
+- [guile-1.8 >= 1.8.5],
+- [GUILE_EFFECTIVE_VERSION=1.8],
+- [AC_MSG_ERROR([
+- guile does not appear to be installed correctly, or is not in the
+- correct version range. Perhaps you have not installed the guile
+- development packages? Gnucash requires at least version 1.8.5 to build.
+- ])])
+-])
+
+-AM_CONDITIONAL(GNC_HAVE_GUILE_2, test "x${gnc_have_guile_2}" = xyes)
++AC_ARG_WITH([guile],
++ AS_HELP_STRING([--with-guile=1.8|2.0|auto],
++ [which guile version to compile against @<:@default: auto@:>@]),
++ [],
++ [with_guile=auto]
++)
++
++AS_IF([test "$with_guile" = "2.0"],
++ [PKG_CHECK_MODULES(GUILE, [guile-2.0 >= 2.0.0],
++ [GUILE_EFFECTIVE_VERSION=2.0
++ AC_PATH_PROG([GUILD], guild)])],
++ [test "$with_guile" = "1.8"],
++ [PKG_CHECK_MODULES(GUILE, [guile-1.8 >= 1.8.5],
++ [GUILE_EFFECTIVE_VERSION=1.8])],
++ [test "$with_guile" = "auto"],
++ [PKG_CHECK_MODULES(GUILE, [guile-2.0 >= 2.0.0],
++ [GUILE_EFFECTIVE_VERSION=2.0
++ AC_PATH_PROG([GUILD], guild)],
++ [PKG_CHECK_MODULES(GUILE, [guile-1.8 >= 1.8.5],
++ [GUILE_EFFECTIVE_VERSION=1.8],
++ [GUILE_EFFECTIVE_VERSION=0])
++ ])],
++ # else
++ [AC_MSG_ERROR([invalid guile version specified])]
++)
++
++AS_IF([test "$GUILE_EFFECTIVE_VERSION" = "0"],
++ [AC_MSG_ERROR([
++ guile does not appear to be installed correctly, or is not in the
++ correct version range. Perhaps you have not installed the guile
++ development packages? Gnucash requires at least version 1.8.5 to build.
++ ])]
++)
++
++AM_CONDITIONAL(GNC_HAVE_GUILE_2, [test "$GUILE_EFFECTIVE_VERSION" = "2.0"])
+ AC_SUBST(GUILE_EFFECTIVE_VERSION)
+ AC_SUBST(GUILE, [`pwd`/gnc-guile])
+
+@@ -584,7 +603,7 @@ if test "${BUILDING_FROM_VCS}" = yes
+ then
+ AX_PKG_SWIG(2.0.10, [gnc_have_swig_2_0_10=yes], [gnc_have_swig_2_0_10=no])
+
+- if test "${gnc_have_guile_2}" = yes
++ if test "${GUILE_EFFECTIVE_VERSION}" = "2.0"
+ then
+ if test "${gnc_have_swig_2_0_10}" = no
+ then
+--
+2.6.3
+
diff --git a/app-office/gnucash/gnucash-2.6.9.ebuild b/app-office/gnucash/gnucash-2.6.9.ebuild
index 4daf665d46cd..d06c27b3e03a 100644
--- a/app-office/gnucash/gnucash-2.6.9.ebuild
+++ b/app-office/gnucash/gnucash-2.6.9.ebuild
@@ -64,6 +64,9 @@ src_prepare() {
# Skip test that needs some locales to be present
sed -i -e '/test_suite_gnc_date/d' src/libqof/qof/test/test-qof.c || die
+ # Fix automagic on guile detection
+ epatch "${FILESDIR}"/${PN}-2.6.9-automagic-guile.patch
+
eautoreconf
gnome2_src_prepare
}
@@ -86,6 +89,7 @@ src_configure() {
$(use_enable ofx) \
$(use_enable hbci aqbanking) \
$(use_enable python) \
+ --with-guile=1.8 \
--disable-doxygen \
--disable-gtkmm \
--enable-locale-specific-tax \