summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-29 04:01:47 +0000
committerSam James <sam@gentoo.org>2020-12-29 04:06:54 +0000
commit97fbed22dec63814f4313eff496eef393ec4927f (patch)
treed5aa3d663cca21a422041c1cdac14fc4990e0faf /app-office
parentdev-python/rq: cleanup old (diff)
downloadgentoo-97fbed22dec63814f4313eff496eef393ec4927f.tar.gz
gentoo-97fbed22dec63814f4313eff496eef393ec4927f.tar.bz2
gentoo-97fbed22dec63814f4313eff496eef393ec4927f.zip
app-office/texstudio: bump to 3.0.2
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texstudio/Manifest1
-rw-r--r--app-office/texstudio/texstudio-3.0.2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/app-office/texstudio/Manifest b/app-office/texstudio/Manifest
index 6bd01f7372e6..2d325d5963d7 100644
--- a/app-office/texstudio/Manifest
+++ b/app-office/texstudio/Manifest
@@ -1,2 +1,3 @@
DIST texstudio-3.0.0_pre20200601.tar.gz 35982392 BLAKE2B 1eed56fe21aac141df41f251621a902a20153b0eaafc995b56fa8c3fbcc213685710e45202fbb90a071a0efac591c86588d4c5fe3727e603e0a58e149ed6864e SHA512 d922f576055fc345e7e0125074c6dbb473c6fb95aa06ae1ffc15f3b89fbdc7c5a44a13d4a32b770bef10c7bae7211a4bf3a269996eda1b3a0c8fd1ed8f3c4bb1
DIST texstudio-3.0.1-r1.tar.gz 36144393 BLAKE2B 63dad681a56ce60a90c44ab71930e8a14a7f335eb7d40f906aab2f5ca10375f768bafc3ae9023574b04c2b5196bc495ef47fb5fc9d4f6438da0a747ebd857972 SHA512 aba57d9f45af259131d3ab47463a30bec24d8fa5b30a9c574308b8a7d6c1117acb1553df20ebe5855281510f82c4d55700a0db0dffeee1b69f2afec234e18b93
+DIST texstudio-3.0.2.tar.gz 83190497 BLAKE2B b04c035e969c27a9b527a7ab62c3384120c14f4d6178da977a5a3484e0709f63337fdebc23f0231d94376ee0222e7c5724fff74c118d311388af73e1470518f7 SHA512 68581f21487f3fb3d27b64650901396e4abdb0df9edbf8796efd5b8b31cc26b5fce123a09f704bafd7994f129c392f96e5a0af46fb637a64b5230251e1517f0d
diff --git a/app-office/texstudio/texstudio-3.0.2.ebuild b/app-office/texstudio/texstudio-3.0.2.ebuild
new file mode 100644
index 000000000000..2ad5ecb8a4df
--- /dev/null
+++ b/app-office/texstudio/texstudio-3.0.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop prefix qmake-utils xdg
+
+MY_PV="${PV/_/}"
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
+SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="video"
+
+COMMON_DEPEND="
+ app-text/hunspell:=
+ app-text/poppler[qt5]
+ >=dev-libs/quazip-0.7.2[qt5(+)]
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsvg:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ video? ( media-libs/phonon[qt5(+)] )"
+RDEPEND="${COMMON_DEPEND}
+ app-text/ghostscript-gpl
+ app-text/psutils
+ media-libs/netpbm
+ virtual/latex-base"
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed \
+ -e '/qtsingleapplication.pri/d' \
+ -i ${PN}.pro || die
+
+ cp "${FILESDIR}"/texmakerx_my.pri ${PN}.pri || die
+ eprefixify ${PN}.pri
+}
+
+src_configure() {
+ eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+ newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
+ done
+ emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+}