summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-07-26 09:39:17 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-07-26 09:39:17 +0200
commit9c1e96216f410c4ab68dd91b575609cde1d9c842 (patch)
treec986eaeae368ce1c3104a18655c3e5051d279a91 /app-office
parentdev-perl/CPAN-Mini: Bump to version 1.111.16 (diff)
downloadgentoo-9c1e96216f410c4ab68dd91b575609cde1d9c842.tar.gz
gentoo-9c1e96216f410c4ab68dd91b575609cde1d9c842.tar.bz2
gentoo-9c1e96216f410c4ab68dd91b575609cde1d9c842.zip
app-office/libreoffice: Fixed building with >=net-misc/curl-7.50.0
Gentoo bug #589578 Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-curl-7.50.0.patch23
-rw-r--r--app-office/libreoffice/libreoffice-5.1.4.2.ebuild1
2 files changed, 24 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/libreoffice-curl-7.50.0.patch b/app-office/libreoffice/files/libreoffice-curl-7.50.0.patch
new file mode 100644
index 000000000000..4a947d0a76d1
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-curl-7.50.0.patch
@@ -0,0 +1,23 @@
+From 0b8e589875ffd84150470832de18ebd79989efc0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
+Date: Mon, 25 Jul 2016 12:08:35 +0100
+Subject: curl 7.50.0 has CURL as typedef struct Curl_easy
+
+Change-Id: I22e5e2cdf78c38087579071c1b1570a8adc7d3c4
+
+diff --git a/ucb/source/ucp/ftp/ftploaderthread.cxx b/ucb/source/ucp/ftp/ftploaderthread.cxx
+index be68d9a..315ccb7 100644
+--- a/ucb/source/ucp/ftp/ftploaderthread.cxx
++++ b/ucb/source/ucp/ftp/ftploaderthread.cxx
+@@ -71,7 +71,7 @@ FTPLoaderThread::~FTPLoaderThread() {
+
+
+ CURL* FTPLoaderThread::handle() {
+- CURL* ret = osl_getThreadKeyData(m_threadKey);
++ CURL* ret = static_cast<CURL*>(osl_getThreadKeyData(m_threadKey));
+ if(!ret) {
+ ret = curl_easy_init();
+ if (ret != nullptr) {
+--
+cgit v0.10.2
+
diff --git a/app-office/libreoffice/libreoffice-5.1.4.2.ebuild b/app-office/libreoffice/libreoffice-5.1.4.2.ebuild
index 52653526c38b..c0c279216ff4 100644
--- a/app-office/libreoffice/libreoffice-5.1.4.2.ebuild
+++ b/app-office/libreoffice/libreoffice-5.1.4.2.ebuild
@@ -244,6 +244,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
PATCHES=(
# from 5.2 branch
"${FILESDIR}/${PN}-5.1.4.2-gcc6.patch"
+ "${FILESDIR}/${PN}-curl-7.50.0.patch"
# not upstreamable stuff
"${FILESDIR}/${PN}-4.4-system-pyuno.patch"