summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-24 17:59:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-24 19:01:18 +0100
commitaef4348902c525da48c8aa2a07271d0d8d7c9b97 (patch)
tree0399ef61b597d075e6de090bdcd051998b5aa81f /app-office
parentnet-vpn/tor: version bump alpha to 0.4.0.2_alpha (diff)
downloadgentoo-aef4348902c525da48c8aa2a07271d0d8d7c9b97.tar.gz
gentoo-aef4348902c525da48c8aa2a07271d0d8d7c9b97.tar.bz2
gentoo-aef4348902c525da48c8aa2a07271d0d8d7c9b97.zip
app-office/libalkimia: Add USE gmp, EAPI-7 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libalkimia/libalkimia-7.0.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-office/libalkimia/libalkimia-7.0.2-r1.ebuild b/app-office/libalkimia/libalkimia-7.0.2-r1.ebuild
new file mode 100644
index 000000000000..51c04e31c980
--- /dev/null
+++ b/app-office/libalkimia/libalkimia-7.0.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+KMNAME="alkimia"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${KMNAME}/${PV}/${KMNAME}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Library with common classes and functionality used by KDE finance applications"
+HOMEPAGE="https://www.linux-apps.com/content/show.php/libalkimia?content=137323"
+LICENSE="LGPL-2.1"
+SLOT="0/7"
+IUSE="doc gmp"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ $(add_qt_dep qtdbus)
+ !gmp? ( sci-libs/mpir:= )
+ gmp? ( dev-libs/gmp:0=[cxx] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake-utils_use_find_package !gmp MPIR)
+ )
+ kde5_src_configure
+}