summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-27 13:22:01 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-27 13:34:31 +0100
commitd459e1c7f608c32d7e6efd4ba5513d6077440a51 (patch)
treeb9018ded4929dc29e23e5ede59ed03fe8e6b97b2 /app-office
parentMerge remote-tracking branch 'github/pr/260' (diff)
downloadgentoo-d459e1c7f608c32d7e6efd4ba5513d6077440a51.tar.gz
gentoo-d459e1c7f608c32d7e6efd4ba5513d6077440a51.tar.bz2
gentoo-d459e1c7f608c32d7e6efd4ba5513d6077440a51.zip
app-office/texstudio: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texstudio/Manifest1
-rw-r--r--app-office/texstudio/texstudio-2.10.4.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/app-office/texstudio/Manifest b/app-office/texstudio/Manifest
index 4a92895fd3c0..211faf64658c 100644
--- a/app-office/texstudio/Manifest
+++ b/app-office/texstudio/Manifest
@@ -1,2 +1,3 @@
DIST texstudio-2.10.2.tar.gz 25669897 SHA256 0cf97c752ba30aba8a0536492893b71ed454c62e6a6e34cff65a8a4eeb308e64 SHA512 3c29b2ef0bb8ed290c66802ffc9419f39d5ff5c4905523ee3adb7177f1159739639d5e4eb9d038fd28472c6618e68b7839b9c816da462dd24046691ebcd9796c WHIRLPOOL e66da4486fa17aa940557af75a098cd03eeaefabe2bf16d38589a37fd065c313c911f76d44b7b81054ae8460a93da323d3472139445fa67df21bb661143ba607
+DIST texstudio-2.10.4.tar.gz 25810583 SHA256 87e7b7c52d51791178fac4c48feeded7a920bc39bcfb710a745b467d80111c3c SHA512 13c6624bf38ee2633f9a86eb9c7ba03503b63de1f954c3f7c4a24182127b9d4db1e8524a122552412a2ceccb288a0dad3d70e9368fd897d6ec123a16e37816e5 WHIRLPOOL 357796f638d3e558a9560a62d972555474850ebd6b5a61bdaa14037b728113222ce9c9f2438b851fdaa20687e1444a8913cd222d5849de67293b0589085a6dc9
DIST texstudio-2.9.4.tar.gz 25292627 SHA256 dc71590e3745ac193a640667737befd665d549e642e268eec7a8238d3b61b5ea SHA512 6fd35a6490451f9cc3292245857e66d6b0d18d2fb06e0482a8e9bbb8695923c8d3da32a6aa6b8ec591c74ccd81f797ddb958e85db26c90d0096cc678a5f14a49 WHIRLPOOL 9ca5ad727d0096bd986b39b34691167bfafe6ae44c4193fdd1f6f02bdd8c4b8b0cd4ac31af3c1c2833c1ba13f0acf814d3ba14fb0709dc3bbd5ee50729968cdf
diff --git a/app-office/texstudio/texstudio-2.10.4.ebuild b/app-office/texstudio/texstudio-2.10.4.ebuild
new file mode 100644
index 000000000000..fe75dafa7c82
--- /dev/null
+++ b/app-office/texstudio/texstudio-2.10.4.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base fdo-mime prefix qmake-utils
+
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="http://texstudio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/TeXstudio%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="video qt4 +qt5"
+
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4?,qt5?]
+ >=dev-libs/quazip-0.7.1[qt4?,qt5?]
+ dev-qt/qtsingleapplication[qt4?,qt5?]
+ x11-libs/libX11
+ x11-libs/libXext
+ qt4? (
+ dev-qt/designer:4
+ >=dev-qt/qtgui-4.8.5:4
+ >=dev-qt/qtcore-4.6.1:4
+ >=dev-qt/qtscript-4.6.1:4
+ >=dev-qt/qtsvg-4.6.1:4
+ >=dev-qt/qttest-4.6.1:4
+ )
+ qt5? (
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtsvg:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+ video? ( media-libs/phonon[qt4?,qt5?] )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/-/}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.4-hunspell-quazip.patch
+ "${FILESDIR}"/${PN}-2.8.2-desktop.patch
+ )
+
+src_prepare() {
+ find hunspell quazip utilities/poppler-data qtsingleapplication -delete || die
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed \
+ -e '/hunspell.pri/d' \
+ -e '/quazip.pri/d' \
+ -e '/qtsingleapplication.pri/d' \
+ -e '/QUAZIP_STATIC/d' \
+ -i ${PN}.pro || die
+
+# cat >> ${PN}.pro <<- EOF
+# exists(texmakerx_my.pri):include(texmakerx_my.pri)
+# EOF
+
+ cp "${FILESDIR}"/texmakerx_my.pri ${PN}.pri || die
+ eprefixify ${PN}.pri
+
+ epatch ${PATCHES[@]}
+}
+
+src_configure() {
+ if use qt5; then
+ eqmake5
+ else
+ eqmake4
+ fi
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+ insinto /usr/share/icons/hicolor/${i}
+ newins utilities/${PN}${i}.png ${PN}.png
+ done
+ emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}