summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-12-13 20:00:30 +0200
committerMart Raudsepp <leio@gentoo.org>2020-12-13 20:47:41 +0200
commite643d66299e3bf059a6b0ceaacee0df36519c314 (patch)
treeedf6e1ae182a8fbe87934b1cd9088c77928a15e3 /app-office
parentgnome-extra/evolution-ews: bump to 3.38.2 (diff)
downloadgentoo-e643d66299e3bf059a6b0ceaacee0df36519c314.tar.gz
gentoo-e643d66299e3bf059a6b0ceaacee0df36519c314.tar.bz2
gentoo-e643d66299e3bf059a6b0ceaacee0df36519c314.zip
app-office/glabels: fix compilation with gcc-10
Closes: https://bugs.gentoo.org/721968 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/glabels/files/glabels-externs.patch24
-rw-r--r--app-office/glabels/glabels-3.4.1.ebuild4
2 files changed, 28 insertions, 0 deletions
diff --git a/app-office/glabels/files/glabels-externs.patch b/app-office/glabels/files/glabels-externs.patch
new file mode 100644
index 000000000000..5722912154bb
--- /dev/null
+++ b/app-office/glabels/files/glabels-externs.patch
@@ -0,0 +1,24 @@
+diff -up glabels-3.4.1/src/font-history.h.f32 glabels-3.4.1/src/font-history.h
+--- glabels-3.4.1/src/font-history.h.f32 2016-03-04 05:01:15.000000000 +0100
++++ glabels-3.4.1/src/font-history.h 2020-02-03 08:41:46.371176433 +0100
+@@ -28,7 +28,7 @@
+ G_BEGIN_DECLS
+
+
+-glFontHistoryModel *gl_font_history;
++extern glFontHistoryModel *gl_font_history;
+
+
+ void gl_font_history_init (void);
+diff -up glabels-3.4.1/src/template-history.h.f32 glabels-3.4.1/src/template-history.h
+--- glabels-3.4.1/src/template-history.h.f32 2016-03-04 05:01:15.000000000 +0100
++++ glabels-3.4.1/src/template-history.h 2020-02-03 08:42:28.547175850 +0100
+@@ -28,7 +28,7 @@
+ G_BEGIN_DECLS
+
+
+-glTemplateHistoryModel *gl_template_history;
++extern glTemplateHistoryModel *gl_template_history;
+
+
+ void gl_template_history_init (void);
diff --git a/app-office/glabels/glabels-3.4.1.ebuild b/app-office/glabels/glabels-3.4.1.ebuild
index 23065b3be108..2f70ff77c791 100644
--- a/app-office/glabels/glabels-3.4.1.ebuild
+++ b/app-office/glabels/glabels-3.4.1.ebuild
@@ -32,6 +32,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/glabels-externs.patch # Fix compilation with -fno-common/gcc10; patch from Fedora
+)
+
src_configure() {
gnome2_src_configure \
$(use_with eds libebook) \