summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-26 16:48:40 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-26 16:49:02 +0200
commitf0d53ac90bf31f73069fa3bb81947ee1c5c81df2 (patch)
tree2e05966c851c93faccec2ced67e34bfe96bb5afb /app-office
parentsys-devel/patch: fix error handling with git-style patches (diff)
downloadgentoo-f0d53ac90bf31f73069fa3bb81947ee1c5c81df2.tar.gz
gentoo-f0d53ac90bf31f73069fa3bb81947ee1c5c81df2.tar.bz2
gentoo-f0d53ac90bf31f73069fa3bb81947ee1c5c81df2.zip
app-office/calcurse: revision bump.
... so as to make Soap happy. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calcurse/calcurse-4.3.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-office/calcurse/calcurse-4.3.0-r1.ebuild b/app-office/calcurse/calcurse-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..451271ee693f
--- /dev/null
+++ b/app-office/calcurse/calcurse-4.3.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="a text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64"
+
+RDEPEND="
+ dev-python/httplib2
+ sys-libs/ncurses:0="
+
+DEPEND="
+ ${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2.1-tinfo.patch
+)
+
+# Most tests fail.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+}
+
+src_install() {
+ multilib-minimal_src_install
+}