summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/libopensync-plugin-syncml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/libopensync-plugin-syncml')
-rw-r--r--app-pda/libopensync-plugin-syncml/Manifest1
-rw-r--r--app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild37
-rw-r--r--app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-9999.ebuild38
-rw-r--r--app-pda/libopensync-plugin-syncml/metadata.xml13
4 files changed, 89 insertions, 0 deletions
diff --git a/app-pda/libopensync-plugin-syncml/Manifest b/app-pda/libopensync-plugin-syncml/Manifest
new file mode 100644
index 000000000000..b13c4d3df6f4
--- /dev/null
+++ b/app-pda/libopensync-plugin-syncml/Manifest
@@ -0,0 +1 @@
+DIST libopensync-plugin-syncml-0.39.tar.bz2 65557 SHA256 fd1bf079d804e7f8d16cec3eb743c0f7df3379f46ae037387b8b06be8392bbdd SHA512 9f7c48e6ec97f989228c6bf79bb4e5a81e5d078b613ce84d3254781fe6b17cde328aa0179463c8306a17aa8596d5ed0b06aee5bb5b43171b086729661beee91b WHIRLPOOL da77a036269371a2b1c56c16fc26455d919f73ecc1f800387d3d5c6c315863233947e785b7f6bc7c2170bff8ebea95ed1d580b92fb81f42b1dc41b30fdf17e41
diff --git a/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild
new file mode 100644
index 000000000000..dfdf43650771
--- /dev/null
+++ b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.39.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit cmake-utils
+
+DESCRIPTION="OpenSync SyncML Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="http +obex"
+
+REQUIRED_USE="|| ( http obex )"
+
+RDEPEND="~app-pda/libopensync-${PV}
+ dev-libs/glib:2
+ dev-libs/libxml2
+ >=app-pda/libsyncml-0.5.0[obex?,http?]"
+DEPEND="${RDEPEND}"
+
+# FIXME: % tests passed, 2 tests failed out of 2
+RESTRICT="test"
+
+src_configure() {
+ DOCS="AUTHORS"
+
+ local mycmakeargs="
+ $(cmake-utils_use_enable http HTTP)
+ $(cmake-utils_use_enable obex OBEX)"
+
+ cmake-utils_src_configure
+}
diff --git a/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-9999.ebuild b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-9999.ebuild
new file mode 100644
index 000000000000..0fb4dfa72418
--- /dev/null
+++ b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit cmake-utils subversion
+
+DESCRIPTION="OpenSync SyncML Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI=""
+
+ESVN_REPO_URI="http://svn.opensync.org/plugins/syncml/trunk"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="http +obex"
+
+REQUIRED_USE="|| ( http obex )"
+
+RDEPEND="~app-pda/libopensync-${PV}
+ ~app-pda/libsyncml-${PV}[obex?,http?]
+ dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+src_configure() {
+ DOCS="AUTHORS"
+
+ local mycmakeargs="
+ $(cmake-utils_use_enable http HTTP)
+ $(cmake-utils_use_enable obex OBEX)"
+
+ cmake-utils_src_configure
+}
diff --git a/app-pda/libopensync-plugin-syncml/metadata.xml b/app-pda/libopensync-plugin-syncml/metadata.xml
new file mode 100644
index 000000000000..498754bb0060
--- /dev/null
+++ b/app-pda/libopensync-plugin-syncml/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pda</herd>
+<maintainer>
+ <email>rhill@gentoo.org</email>
+ <name>Ryan Hill</name>
+</maintainer>
+<use>
+ <flag name='http'>Enable http transports</flag>
+ <flag name='obex'>Enable obex transports</flag>
+</use>
+</pkgmetadata>