summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/synce-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/synce-core')
-rw-r--r--app-pda/synce-core/Manifest1
-rw-r--r--app-pda/synce-core/metadata.xml8
-rw-r--r--app-pda/synce-core/synce-core-0.16-r1.ebuild79
3 files changed, 88 insertions, 0 deletions
diff --git a/app-pda/synce-core/Manifest b/app-pda/synce-core/Manifest
new file mode 100644
index 000000000000..8cf0dc41b7f1
--- /dev/null
+++ b/app-pda/synce-core/Manifest
@@ -0,0 +1 @@
+DIST synce-core-0.16.tar.gz 703275 SHA256 e1b120bbbc9728b43ff4d3c82f521dd0e55560356c9e2ce2f059cc5f44edd641 SHA512 eb5fc6743ea77ff8e27b5e96300a120a78510be16ba846b20ec0c99e3e969d4af649566e46addb0e3a88da875639e6b150a7cda8dcee706235fe9103f9ffe8ff WHIRLPOOL 226a581e7abbd7c4d0631fd31a4203678f6ea8bbe15c42a88bfed03898deb19edc9a25c68f9d906e7a53c62f6a7d2ad26f4030b80e7202aebf47b5add3ec4a86
diff --git a/app-pda/synce-core/metadata.xml b/app-pda/synce-core/metadata.xml
new file mode 100644
index 000000000000..ba58102c22c2
--- /dev/null
+++ b/app-pda/synce-core/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <upstream>
+ <remote-id type="sourceforge">synce</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-pda/synce-core/synce-core-0.16-r1.ebuild b/app-pda/synce-core/synce-core-0.16-r1.ebuild
new file mode 100644
index 000000000000..6cccd8ec79dd
--- /dev/null
+++ b/app-pda/synce-core/synce-core-0.16-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.7"
+
+inherit flag-o-matic python
+
+DESCRIPTION="Base libraries, including RAPI protocol, tools and dccm daemon"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python static-libs"
+
+# AC_PATH_PROG -> pppd -> net-dialup/ppp
+# AC_PATH_PROG -> ifconfig -> sys-apps/net-tools
+RDEPEND="!app-pda/synce-connector
+ >=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.28
+ !dev-libs/librapi2
+ !dev-libs/libsynce
+ net-dialup/ppp
+ sys-apps/net-tools
+ virtual/libgudev
+ virtual/udev
+ python? (
+ >=dev-python/pyrex-0.9.6
+ dev-python/python-gudev
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # AC_PATH_PROG -> dhclient ->
+ local dhclient=true
+ type -P dhclient >/dev/null && dhclient=dhclient
+ sed -i -e "s:dhclient:${dhclient}:" configure || die
+
+ use python && python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+
+ # hal OR udev -> udev -> dbus -> build all of bluetooth, odccm, udev
+ econf \
+ $(use_enable static-libs static) \
+ --enable-dccm-file-support \
+ --enable-odccm-support \
+ --disable-hal-support \
+ --enable-udev-support \
+ --enable-bluetooth-support \
+ $(use_enable python python-bindings)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc BUGS ChangeLog README* TODO
+ newdoc bluetooth/README README.bluetooth
+
+ # prune_libtool_files() from eutils.eclass fails wrt #421197
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ # Always remove static archive from site-packages
+ use static-libs && find "${ED}" -name pyrapi2.a -exec rm -f {} +
+}