summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-13 23:40:09 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-13 23:44:15 +0200
commit40ae227b3b2b2a87ab0722a30024d407082648a9 (patch)
treeb35a7e214f36657ac2e086f1e8b7cc769f23630c /app-portage/cpuid2cpuflags
parentapp-portage/cpuinfo2cpuflags: Update homepage and URIs (diff)
downloadgentoo-40ae227b3b2b2a87ab0722a30024d407082648a9.tar.gz
gentoo-40ae227b3b2b2a87ab0722a30024d407082648a9.tar.bz2
gentoo-40ae227b3b2b2a87ab0722a30024d407082648a9.zip
app-portage/cpuinfo2cpuflags: Rename to cpuid2cpuflags
Diffstat (limited to 'app-portage/cpuid2cpuflags')
-rw-r--r--app-portage/cpuid2cpuflags/Manifest2
-rw-r--r--app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild40
-rw-r--r--app-portage/cpuid2cpuflags/cpuid2cpuflags-2.ebuild17
-rw-r--r--app-portage/cpuid2cpuflags/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/app-portage/cpuid2cpuflags/Manifest b/app-portage/cpuid2cpuflags/Manifest
new file mode 100644
index 000000000000..8f4b6b6512ab
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/Manifest
@@ -0,0 +1,2 @@
+DIST cpuinfo2cpuflags-1.tar.gz 1429 SHA256 aaa4b80568936acc4b2798f62254a5170328c862cadc70b22cd10e4e6716bbcc SHA512 68a21cfdb0fc8c6eb5aad5c6702d50dd56c927b2010efea1651dbc6a9657654b770bc5a4055fb11e790066c2c63c9ea29c3e03d91057abe187e7029e6797aede WHIRLPOOL 57c66d7eddbf6245735f037980a3d7a685dbccc11bba7e7dd0e1290a77960f17cdb81f161c012abc0eec213b951709df8d7677f0034d5b083bc6f45be1386ad8
+DIST cpuinfo2cpuflags-2.tar.bz2 68939 SHA256 a8779df6fbd5f7d3b92580b0b73242a209bedd4e8204ea04d1d811e1ca6d5cba SHA512 672042112e6430edb0dbfd82d3de2088324544e7bcd81b1c3376d5a85b5f7da91b0e1c92d00d575adb861091b33de599a05edc9a75d0ef76a253ca077276127c WHIRLPOOL f64c040a4a6b8c193447d6c01aa2ba18af5c1232c6a7b0f9f794f5792c39d7c4288c190d135f2c80475dbf5fc3f187496edab4861209209311cdcd0e4218c7d8
diff --git a/app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild b/app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild
new file mode 100644
index 000000000000..e31a359545a3
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/cpuid2cpuflags-1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit python-r1
+
+MY_PN=cpuinfo2cpuflags
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Script to guess CPU_FLAGS_X86 flags from /proc/cpuinfo"
+HOMEPAGE="https://github.com/mgorny/cpuid2cpuflags"
+SRC_URI="https://github.com/mgorny/cpuid2cpuflags/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=${PYTHON_DEPS}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ python_foreach_impl python_newscript "${MY_PN}-x86"{.py,}
+}
+
+pkg_postinst() {
+ if has_version 'sys-apps/portage' \
+ && ! has_version "sys-apps/portage[${PYTHON_USEDEP}]"
+ then
+ ewarn "Support for matching Python implementations should be enabled"
+ ewarn "on sys-apps/portage as well. Otherwise, cpuinfo2cpuflags won't"
+ ewarn "be able to figure out the correct repository location and will"
+ ewarn "require you to specify it explicitly."
+ fi
+}
diff --git a/app-portage/cpuid2cpuflags/cpuid2cpuflags-2.ebuild b/app-portage/cpuid2cpuflags/cpuid2cpuflags-2.ebuild
new file mode 100644
index 000000000000..5c625c7cf062
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/cpuid2cpuflags-2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=cpuinfo2cpuflags-${PV}
+DESCRIPTION="Tool to guess CPU_FLAGS_X86 flags for the host"
+HOMEPAGE="https://github.com/mgorny/cpuid2cpuflags"
+SRC_URI="https://github.com/mgorny/cpuid2cpuflags/releases/download/v${PV}/${MY_P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
diff --git a/app-portage/cpuid2cpuflags/metadata.xml b/app-portage/cpuid2cpuflags/metadata.xml
new file mode 100644
index 000000000000..422aab7218c1
--- /dev/null
+++ b/app-portage/cpuid2cpuflags/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mgorny/cpuid2cpuflags</remote-id>
+ </upstream>
+</pkgmetadata>