summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/cpuinfo2cpuflags
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/cpuinfo2cpuflags')
-rw-r--r--app-portage/cpuinfo2cpuflags/Manifest2
-rw-r--r--app-portage/cpuinfo2cpuflags/cpuinfo2cpuflags-1.ebuild36
-rw-r--r--app-portage/cpuinfo2cpuflags/cpuinfo2cpuflags-2.ebuild14
-rw-r--r--app-portage/cpuinfo2cpuflags/metadata.xml11
4 files changed, 63 insertions, 0 deletions
diff --git a/app-portage/cpuinfo2cpuflags/Manifest b/app-portage/cpuinfo2cpuflags/Manifest
new file mode 100644
index 000000000000..8f4b6b6512ab
--- /dev/null
+++ b/app-portage/cpuinfo2cpuflags/Manifest
@@ -0,0 +1,2 @@
+DIST cpuinfo2cpuflags-1.tar.gz 1429 SHA256 aaa4b80568936acc4b2798f62254a5170328c862cadc70b22cd10e4e6716bbcc SHA512 68a21cfdb0fc8c6eb5aad5c6702d50dd56c927b2010efea1651dbc6a9657654b770bc5a4055fb11e790066c2c63c9ea29c3e03d91057abe187e7029e6797aede WHIRLPOOL 57c66d7eddbf6245735f037980a3d7a685dbccc11bba7e7dd0e1290a77960f17cdb81f161c012abc0eec213b951709df8d7677f0034d5b083bc6f45be1386ad8
+DIST cpuinfo2cpuflags-2.tar.bz2 68939 SHA256 a8779df6fbd5f7d3b92580b0b73242a209bedd4e8204ea04d1d811e1ca6d5cba SHA512 672042112e6430edb0dbfd82d3de2088324544e7bcd81b1c3376d5a85b5f7da91b0e1c92d00d575adb861091b33de599a05edc9a75d0ef76a253ca077276127c WHIRLPOOL f64c040a4a6b8c193447d6c01aa2ba18af5c1232c6a7b0f9f794f5792c39d7c4288c190d135f2c80475dbf5fc3f187496edab4861209209311cdcd0e4218c7d8
diff --git a/app-portage/cpuinfo2cpuflags/cpuinfo2cpuflags-1.ebuild b/app-portage/cpuinfo2cpuflags/cpuinfo2cpuflags-1.ebuild
new file mode 100644
index 000000000000..2954fe7f013a
--- /dev/null
+++ b/app-portage/cpuinfo2cpuflags/cpuinfo2cpuflags-1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit python-r1
+
+DESCRIPTION="Script to guess CPU_FLAGS_X86 flags from /proc/cpuinfo"
+HOMEPAGE="https://bitbucket.org/mgorny/cpuinfo2cpuflags"
+SRC_URI="https://bitbucket.org/mgorny/cpuinfo2cpuflags/downloads/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=${PYTHON_DEPS}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_install() {
+ python_foreach_impl python_newscript "${PN}-x86"{.py,}
+}
+
+pkg_postinst() {
+ if has_version 'sys-apps/portage' \
+ && ! has_version "sys-apps/portage[${PYTHON_USEDEP}]"
+ then
+ ewarn "Support for matching Python implementations should be enabled"
+ ewarn "on sys-apps/portage as well. Otherwise, cpuinfo2cpuflags won't"
+ ewarn "be able to figure out the correct repository location and will"
+ ewarn "require you to specify it explicitly."
+ fi
+}
diff --git a/app-portage/cpuinfo2cpuflags/cpuinfo2cpuflags-2.ebuild b/app-portage/cpuinfo2cpuflags/cpuinfo2cpuflags-2.ebuild
new file mode 100644
index 000000000000..bb1061699e90
--- /dev/null
+++ b/app-portage/cpuinfo2cpuflags/cpuinfo2cpuflags-2.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Tool to guess CPU_FLAGS_X86 flags for the host"
+HOMEPAGE="https://bitbucket.org/mgorny/cpuinfo2cpuflags"
+SRC_URI="https://bitbucket.org/mgorny/cpuinfo2cpuflags/downloads/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
diff --git a/app-portage/cpuinfo2cpuflags/metadata.xml b/app-portage/cpuinfo2cpuflags/metadata.xml
new file mode 100644
index 000000000000..b995c192eb02
--- /dev/null
+++ b/app-portage/cpuinfo2cpuflags/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">mgorny/cpuinfo2cpuflags</remote-id>
+ </upstream>
+</pkgmetadata>