summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-21 18:00:19 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-21 19:12:32 +0100
commitb38770835efdf694382b235b94adb378faab0a99 (patch)
tree59b6a740b8f679eff50c5494654407f01b810ee8 /app-portage/distpatch/distpatch-0.1.2-r1.ebuild
parentapp-portage/demerge: Support sys-apps/portage-mgorny (diff)
downloadgentoo-b38770835efdf694382b235b94adb378faab0a99.tar.gz
gentoo-b38770835efdf694382b235b94adb378faab0a99.tar.bz2
gentoo-b38770835efdf694382b235b94adb378faab0a99.zip
app-portage/distpatch: Support sys-apps/portage-mgorny
Diffstat (limited to 'app-portage/distpatch/distpatch-0.1.2-r1.ebuild')
-rw-r--r--app-portage/distpatch/distpatch-0.1.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-portage/distpatch/distpatch-0.1.2-r1.ebuild b/app-portage/distpatch/distpatch-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..351cdc02b9cf
--- /dev/null
+++ b/app-portage/distpatch/distpatch-0.1.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distfile Patching Support for Gentoo Linux (tools)"
+HOMEPAGE="https://github.com/rafaelmartins/distpatch"
+SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ || (
+ >=sys-apps/portage-2.1.8.3
+ sys-apps/portage-mgorny
+ )
+ dev-python/snakeoil"
+DEPEND="${CDEPEND}
+ dev-python/setuptools"
+RDEPEND="${CDEPEND}
+ >=dev-util/diffball-1.0.1"