summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/emerge-delta-webrsync/emerge-delta-webrsync-3.7.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/emerge-delta-webrsync/emerge-delta-webrsync-3.7.2-r1.ebuild')
-rw-r--r--app-portage/emerge-delta-webrsync/emerge-delta-webrsync-3.7.2-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-portage/emerge-delta-webrsync/emerge-delta-webrsync-3.7.2-r1.ebuild b/app-portage/emerge-delta-webrsync/emerge-delta-webrsync-3.7.2-r1.ebuild
new file mode 100644
index 000000000000..badaf5b7066d
--- /dev/null
+++ b/app-portage/emerge-delta-webrsync/emerge-delta-webrsync-3.7.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+DESCRIPTION="emerge-webrsync using patches to minimize bandwidth"
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
+SRC_URI="https://raw.githubusercontent.com/gentoo/portage/779a9e686d89e31af43e33b1163b01aeff65d7ea/misc/emerge-delta-webrsync -> ${P}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-shells/bash
+ >=sys-apps/portage-2.1.10
+ >=dev-util/diffball-0.6.5"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}/${P}" "${WORKDIR}/" || die
+}
+
+src_prepare() {
+ # Remove premature `rm -fr "${TMPDIR}"` for bug #506192.
+ sed -e '334,336d' -i ${P} || die
+}
+
+src_install() {
+ newbin ${P} ${PN}
+ keepdir /var/delta-webrsync
+ fperms 0770 /var/delta-webrsync
+}
+
+pkg_preinst() {
+ # Failure here is non-fatal, since the "portage" group
+ # doesn't necessarily exist on prefix systems.
+ chgrp portage "${ED}"/var/delta-webrsync 2>/dev/null
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] && \
+ ! has_version app-arch/tarsync ; then
+ elog "For maximum emerge-delta-webrsync" \
+ "performance, install app-arch/tarsync."
+ fi
+}