summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/epm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/epm')
-rw-r--r--app-portage/epm/Manifest1
-rw-r--r--app-portage/epm/epm-1.40.ebuild33
-rw-r--r--app-portage/epm/epm-9999.ebuild34
-rw-r--r--app-portage/epm/files/epm-1.40-prefix.patch32
-rw-r--r--app-portage/epm/metadata.xml17
5 files changed, 117 insertions, 0 deletions
diff --git a/app-portage/epm/Manifest b/app-portage/epm/Manifest
new file mode 100644
index 000000000000..dc48794eaec4
--- /dev/null
+++ b/app-portage/epm/Manifest
@@ -0,0 +1 @@
+DIST epm-1.40.tar.gz 10980 SHA256 da435cc7a86807f9a1575afdb0ed6bdef26a9b7d0f1d8b91550b1aacf75eeefc SHA512 745c7f902fb35672058b05763a308322fb891b5dcc4f37a0444fdc22f1802ec5e8479445537c299e23dcf3882259751a163e356a633e270a2386a1456b541103 WHIRLPOOL f61f47480108d477afee7fdab549894898ea70ba61a004fef99885390c5eeab601bb271db73b301fd94093266be05496c9308031fd98f27bd0c58e53fb91b036
diff --git a/app-portage/epm/epm-1.40.ebuild b/app-portage/epm/epm-1.40.ebuild
new file mode 100644
index 000000000000..01618ee77ee7
--- /dev/null
+++ b/app-portage/epm/epm-1.40.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils prefix
+
+DESCRIPTION="rpm workalike for Gentoo Linux"
+HOMEPAGE="https://github.com/fuzzyray/epm"
+SRC_URI="http://www.gentoo.org/~fuzzyray/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-prefix.patch
+ eprefixify epm
+}
+
+src_compile() {
+ pod2man epm > epm.1 || die "pod2man failed"
+}
+
+src_install() {
+ dobin epm || die
+ doman epm.1
+}
diff --git a/app-portage/epm/epm-9999.ebuild b/app-portage/epm/epm-9999.ebuild
new file mode 100644
index 000000000000..e07c494c43dc
--- /dev/null
+++ b/app-portage/epm/epm-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils git-2
+
+DESCRIPTION="rpm workalike for Gentoo Linux"
+HOMEPAGE="https://github.com/fuzzyray/epm"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/fuzzyray/epm.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i "s/\"EPM version .*\";/\"EPM version 9999-${EGIT_VERSION}\";/" epm \
+ || die "Failed to set version"
+}
+
+src_compile() {
+ pod2man epm > epm.1 || die "pod2man failed"
+}
+
+src_install() {
+ dobin epm || die
+ doman epm.1
+}
diff --git a/app-portage/epm/files/epm-1.40-prefix.patch b/app-portage/epm/files/epm-1.40-prefix.patch
new file mode 100644
index 000000000000..957a5cb43838
--- /dev/null
+++ b/app-portage/epm/files/epm-1.40-prefix.patch
@@ -0,0 +1,32 @@
+--- epm.orig 2012-12-27 21:21:51.288350173 -0700
++++ epm 2012-12-27 21:26:51.429905384 -0700
+@@ -7,13 +7,13 @@
+ # Global vars
+ (my $version = '$Revision: 1.2 $') =~ s/.*?(\d.*\d).*/EPM version $1/;
+ my $verbose = 0;
+-my $dbpath = '/var/db/pkg';
++my $dbpath = '@GENTOO_PORTAGE_EPREFIX@/var/db/pkg';
+ my $pkgregex =
+ '^.+?\/'. # group (ignored)
+ '(.+?)'. # name
+ '-(\d+(?:\.\d+)*\w*)'. # version, eg 1.23.4a
+ '((?:(?:_alpha|_beta|_pre|_rc)\d*)?)'. # special suffix
+- '((?:-r\d+)?)$'; # revision, eg r12
++ '((?:-r\d+)?(?:\.\d+)?)$'; # revision, eg r12 or r01.1
+ my $root = '/';
+ my %opt = (
+ 'dbpath' => \$dbpath,
+@@ -267,11 +267,11 @@
+ if ($opt{'c'}) {
+ # Read in CONFIG_PROTECT from /etc/make.{global,conf}
+ my (@CONFIG_PROTECT) = split ' ',
+- `. /etc/make.globals; . /etc/make.conf; echo \$CONFIG_PROTECT`;
++ `. @GENTOO_PORTAGE_EPREFIX@/etc/make.globals; . @GENTOO_PORTAGE_EPREFIX@/etc/make.conf; echo \$CONFIG_PROTECT`;
+ die "CONFIG_PROTECT is empty" unless @CONFIG_PROTECT;
+ my ($confprotre) = join '|', @CONFIG_PROTECT;
+ @files = grep {
+- (split ' ', $_, 2)[1] =~ /^($confprotre)/o } @files;
++ (split ' ', $_, 2)[1] =~ m!^@GENTOO_PORTAGE_EPREFIX@($confprotre)!o } @files;
+ }
+
+ # Trim @files if doc files requested
diff --git a/app-portage/epm/metadata.xml b/app-portage/epm/metadata.xml
new file mode 100644
index 000000000000..29a0e89cb376
--- /dev/null
+++ b/app-portage/epm/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>gentoo@weilbacher.org</email>
+ <name>Peter Weilbacher</name>
+ <description>Current maintainer, assign bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>fuzzyray@gentoo.org</email>
+ <description>Proxy committer, CC bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fuzzyray/epm</remote-id>
+ </upstream>
+</pkgmetadata>