summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /app-portage/g-cpan
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/g-cpan')
-rw-r--r--app-portage/g-cpan/g-cpan-0.16.7.ebuild3
-rw-r--r--app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild3
-rw-r--r--app-portage/g-cpan/g-cpan-9999.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/app-portage/g-cpan/g-cpan-0.16.7.ebuild b/app-portage/g-cpan/g-cpan-0.16.7.ebuild
index b56c85f37fb1..c8552409d5f7 100644
--- a/app-portage/g-cpan/g-cpan-0.16.7.ebuild
+++ b/app-portage/g-cpan/g-cpan-0.16.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,6 +19,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl/g-cpan"
LICENSE="|| ( Artistic GPL-2 )"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
COMMONDEPEND="
virtual/perl-File-Path
diff --git a/app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild b/app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild
index 074248d01feb..8a9ddc887c58 100644
--- a/app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild
+++ b/app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,6 +19,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl/g-cpan"
LICENSE="|| ( Artistic GPL-2 )"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
COMMONDEPEND="
virtual/perl-File-Path
diff --git a/app-portage/g-cpan/g-cpan-9999.ebuild b/app-portage/g-cpan/g-cpan-9999.ebuild
index 8c06625ef240..fdd2d32c2860 100644
--- a/app-portage/g-cpan/g-cpan-9999.ebuild
+++ b/app-portage/g-cpan/g-cpan-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,6 +19,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl/g-cpan"
LICENSE="|| ( Artistic GPL-2 )"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
COMMONDEPEND="
dev-perl/Config-Tiny