summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-06 18:21:56 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-06 18:22:46 +0200
commitc91aeb7919e56cd9d730914fe069a0d17276b630 (patch)
treec8e65873cd6df0131d05feea5c5f38d5533565f8 /app-portage/gemato
parentapp-text/fb2edit: dependencies fixed (diff)
downloadgentoo-c91aeb7919e56cd9d730914fe069a0d17276b630.tar.gz
gentoo-c91aeb7919e56cd9d730914fe069a0d17276b630.tar.bz2
gentoo-c91aeb7919e56cd9d730914fe069a0d17276b630.zip
app-portage/gemato: Bump to 16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/gemato')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-16.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index d26346813b15..2372a74c99b2 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -3,3 +3,4 @@ DIST gemato-14.5.tar.gz 72752 BLAKE2B 61ca43c92556850afdc8ab1d027aa719d13e77727c
DIST gemato-15.0.tar.gz 73757 BLAKE2B 1315e621ccd10db4b1dea159fe01386e51632716b02dc1a5e797296b506de14506691b4cf9eeb58b66081ae761c1926c1c7fc6f1c1543143fb64e9e5dc47984e SHA512 ed88961bc22df77227c46ff013bafc801f1648827085bc02845b4374f3a4e67cdc79b68cb2bcd31956ac40cb0014e0f5348d79d77394ceed9152b2a0aa30599a
DIST gemato-15.1.tar.gz 71954 BLAKE2B 29a899eb215b78c608f6846c8978837c96df5a69c112c771e4c25c89df268ef22e02bcfb171e9a1b5b2377af101c1029638156c7317e6961133b5a9206747204 SHA512 3263c8e0bc74e1b031775cc37697be5f3214d09ce00ea922af00b8b46638756ee74ad3bc75e73fe8e3563a0ccd5b76986a8f5fc7c00423db863296d89dd233a8
DIST gemato-15.2.tar.gz 72679 BLAKE2B 83e28fa3bc83976538610fec87c3a31e91a18847c107dc7793e16b5421eba69f7b60f8f05195f345ef6f4f8486203e4acbc01bad706b55c20a11480e85a3420c SHA512 5a98040dab0beac64e5e54bd54c6565cd301399709beda9e030ae9206111caf9e792260aa3c6586040060d4be71df3f1368e7554dff6affaa899c4157116faf3
+DIST gemato-16.0.tar.gz 78236 BLAKE2B d4c0d610eb2228be9c439036f7049b9c77d768e91bd30c32a072be5364dd94771dcad32f1194f69a195fb16182f8ecda8cf4769f61cf80e96d9737241ed4080a SHA512 73a1cc588d7541de466c9869eddc5f9347fd15eadeea0ed12c200a8bcf05a933969b80d66d1f61c8d73d9824b83986d4d93188105f047621d161454f22f02f45
diff --git a/app-portage/gemato/gemato-16.0.ebuild b/app-portage/gemato/gemato-16.0.ebuild
new file mode 100644
index 000000000000..d4dfe160f0cc
--- /dev/null
+++ b/app-portage/gemato/gemato-16.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ >=dev-python/pytest-5[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}