summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-01 14:17:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-01 14:22:00 +0200
commiteeda16253769493db3bf50be19d7392302a5e89b (patch)
tree84c659178f43e3aeb8d5a70369f0b4df1223881f /app-portage/gemato
parentdev-python/ipython: Remove old (diff)
downloadgentoo-eeda16253769493db3bf50be19d7392302a5e89b.tar.gz
gentoo-eeda16253769493db3bf50be19d7392302a5e89b.tar.bz2
gentoo-eeda16253769493db3bf50be19d7392302a5e89b.zip
app-portage/gemato: Bump to 16.2
Bug: https://bugs.gentoo.org/745771 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/gemato')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-16.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index c941dc67c94f..188c8dca2f33 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,2 +1,3 @@
DIST gemato-15.2.tar.gz 72679 BLAKE2B 83e28fa3bc83976538610fec87c3a31e91a18847c107dc7793e16b5421eba69f7b60f8f05195f345ef6f4f8486203e4acbc01bad706b55c20a11480e85a3420c SHA512 5a98040dab0beac64e5e54bd54c6565cd301399709beda9e030ae9206111caf9e792260aa3c6586040060d4be71df3f1368e7554dff6affaa899c4157116faf3
DIST gemato-16.1.tar.gz 79946 BLAKE2B 54452ae113cee98f5c8f9ebc880b4ae424510766eb7cd8bc2775c85573388005343061aa9de8f505a72ee92801756f3cb7b67dfd39d9923d0030a4da301f7ce2 SHA512 df21eb8784cc6724874e38ba0192e1e5657483aa031656855fc0c2396179f7352f9450df6b41205425214cf70f2c812a7ee6f55a25334f0fd012b7e710c1de2c
+DIST gemato-16.2.tar.gz 80178 BLAKE2B c973c36bb1277d07618ba8d90f7d6820508d78aedae200f0678c8b2e1dde38e3b7f4d7dc24791dedb9c88791d3b71711c9bdeb749b5fc091a20aa87f71ad70d3 SHA512 9d59ba360afaf237e47c5ded0e5bc29ec44d5b1d73eadadc19ff834a1966e1e620da258eb7a1b6afbff5c66cbd7e39454fd5920f2f82fc510c2f8836c0b80462
diff --git a/app-portage/gemato/gemato-16.2.ebuild b/app-portage/gemato/gemato-16.2.ebuild
new file mode 100644
index 000000000000..4f34edba07fc
--- /dev/null
+++ b/app-portage/gemato/gemato-16.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ >=dev-python/pytest-5[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}