summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-03-31 22:05:47 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-03-31 22:05:47 -0400
commit1c6ef07c301c0f2caf1bff484899d80fb08f4a15 (patch)
tree31f8e86493ab9e3775dd797f614651f198227954 /app-portage/gentoolkit
parentmedia-video/pitivi: Add patch missed in previous commit (diff)
downloadgentoo-1c6ef07c301c0f2caf1bff484899d80fb08f4a15.tar.gz
gentoo-1c6ef07c301c0f2caf1bff484899d80fb08f4a15.tar.bz2
gentoo-1c6ef07c301c0f2caf1bff484899d80fb08f4a15.zip
app-portage/gentoolkit: bump to 0.4.3
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'app-portage/gentoolkit')
-rw-r--r--app-portage/gentoolkit/Manifest1
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.4.3.ebuild77
-rw-r--r--app-portage/gentoolkit/gentoolkit-9999.ebuild34
3 files changed, 96 insertions, 16 deletions
diff --git a/app-portage/gentoolkit/Manifest b/app-portage/gentoolkit/Manifest
index 0bba7e523683..e994394a3796 100644
--- a/app-portage/gentoolkit/Manifest
+++ b/app-portage/gentoolkit/Manifest
@@ -2,3 +2,4 @@ DIST gentoolkit-0.3.3.tar.gz 3197037 BLAKE2B c2a45971f1f25e3008422b63b59042ca0f2
DIST gentoolkit-0.4.0.tar.gz 3215377 BLAKE2B 404f81e2f5bce5da4df122156bc76d225497456ad8ec78a50c41e1183390f8e452a6ce8a3473b5371a6712ce1599be33034c5eed64a1852d116c745bc5a775f4 SHA512 6cf693c588d4a2f5bd06fff4e78ef98007e613348048ec993c5430e168baef6c1da01e1843903f3e87ca8e47dd1ffb207acccbc5c0e881fa3093a7880fec9a56
DIST gentoolkit-0.4.1.tar.gz 3214527 BLAKE2B 1c6be826a099ba4d18ac8fa0bb38808cbf30ee1d93d26c26965d7fa332e6a87f8eee475126f56d68e2a1c0ff04f258f79f5684551b2fe5947d8ac6f6ff3e7079 SHA512 52b665e19dd8b871f4238d05d40a071d69ef114f36b589c29f46686b1439997e72f58896bb4f330ab256af6000a9559426c78cae08640e54b74db343b3b22945
DIST gentoolkit-0.4.2.tar.gz 3215652 BLAKE2B 97b4dcac7293b50161169a6c777623cb1c51e2f74020e0fa2f1f4441c203c03a1269c8c55e1461c5780ebfb8234d364837073d582a52a99f2d40c92e6b77a7f0 SHA512 3a9eac2fd214bcfe39380193cb2118edcd759dbf3eb165e7240525ce1047aa984f1d1f1d3a15324218d9be1f0a1ec960ae08a63191392f1bb3422277a52697ff
+DIST gentoolkit-0.4.3.tar.gz 3218723 BLAKE2B d305db514e48446c0341c1ddc7a6c1bcd464eee11b8ee58f1a16bdf797670a9bb13eacfb2afa666d9ef292ad1dcbdf9970f8ded64bd5d12ca9d73ffae8923119 SHA512 81058d4787b291b6398d82d9a32f41b78d939f8d20ad8afbf9e22a47311ff0a270098c69e53d903ab3ec72a4cd11f13f3be30279a538a6a52972e1651efe447d
diff --git a/app-portage/gentoolkit/gentoolkit-0.4.3.ebuild b/app-portage/gentoolkit/gentoolkit-0.4.3.ebuild
new file mode 100644
index 000000000000..81df6c1880e9
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.4.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_REQ_USE="xml(+),threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoolkit.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="
+ || (
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${DEPEND}
+ sys-apps/gawk
+ sys-apps/gentoo-functions"
+
+python_prepare_all() {
+ python_setup
+ echo VERSION="${PVR}" "${PYTHON}" setup.py set_version
+ VERSION="${PVR}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-0.4.0"; then
+ SHOW_GENTOOKIT_DEV_DEPRECATED_MSG=1
+ fi
+}
+
+pkg_postinst() {
+ # Create cache directory for revdep-rebuild
+ mkdir -p -m 0755 "${EROOT%/}"/var/cache
+ mkdir -p -m 0700 "${EROOT%/}"/var/cache/revdep-rebuild
+
+ if [[ ${SHOW_GENTOOKIT_DEV_DEPRECATED_MSG} ]]; then
+ elog "Starting with version 0.4.0, ebump, ekeyword and imlate are now"
+ elog "part of the gentoolkit package."
+ elog "The gentoolkit-dev package is now deprecated in favor of a single"
+ elog "gentoolkit package. The remaining tools from gentoolkit-dev"
+ elog "are now obsolete/unused with the git based tree."
+ fi
+
+ # Only show the elog information on a new install
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "For further information on gentoolkit, please read the gentoolkit"
+ elog "guide: https://wiki.gentoo.org/wiki/Gentoolkit"
+ elog
+ elog "Another alternative to equery is app-portage/portage-utils"
+ elog
+ elog "Additional tools that may be of interest:"
+ elog
+ elog " app-admin/eclean-kernel"
+ elog " app-portage/diffmask"
+ elog " app-portage/flaggie"
+ elog " app-portage/install-mask"
+ elog " app-portage/portpeek"
+ elog " app-portage/smart-live-rebuild"
+ fi
+}
diff --git a/app-portage/gentoolkit/gentoolkit-9999.ebuild b/app-portage/gentoolkit/gentoolkit-9999.ebuild
index 084927bf88c8..a36db0ec310a 100644
--- a/app-portage/gentoolkit/gentoolkit-9999.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-9999.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6} pypy)
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
PYTHON_REQ_USE="xml(+),threads(+)"
-inherit distutils-r1 git-r3
-
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoolkit.git"
+inherit distutils-r1 git-r3
DESCRIPTION="Collection of administration scripts for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
@@ -26,28 +25,23 @@ DEPEND="
sys-apps/portage-mgorny[${PYTHON_USEDEP}]
)"
RDEPEND="${DEPEND}
- !app-portage/gentoolkit-dev
sys-apps/gawk
sys-apps/gentoo-functions"
python_prepare_all() {
python_setup
- echo VERSION="9999-${EGIT_VERSION}" "${PYTHON}" setup.py set_version
- VERSION="9999-${EGIT_VERSION}" "${PYTHON}" setup.py set_version
+ echo VERSION="${PVR}" "${PYTHON}" setup.py set_version
+ VERSION="${PVR}" "${PYTHON}" setup.py set_version
distutils-r1_python_prepare_all
}
python_install_all() {
distutils-r1_python_install_all
+}
- # remove on Gentoo Prefix platforms where it's broken anyway
- if use prefix; then
- elog "The revdep-rebuild command is removed, the preserve-libs"
- elog "feature of portage will handle issues."
- rm "${ED}"/usr/bin/revdep-rebuild*
- rm "${ED}"/usr/share/man/man1/revdep-rebuild.1
- rm -rf "${ED}"/etc/revdep-rebuild
- rm -rf "${ED}"/var
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-0.4.0"; then
+ SHOW_GENTOOKIT_DEV_DEPRECATED_MSG=1
fi
}
@@ -56,6 +50,14 @@ pkg_postinst() {
mkdir -p -m 0755 "${EROOT%/}"/var/cache
mkdir -p -m 0700 "${EROOT%/}"/var/cache/revdep-rebuild
+ if [[ ${SHOW_GENTOOKIT_DEV_DEPRECATED_MSG} ]]; then
+ elog "Starting with version 0.4.0, ebump, ekeyword and imlate are now"
+ elog "part of the gentoolkit package."
+ elog "The gentoolkit-dev package is now deprecated in favor of a single"
+ elog "gentoolkit package. The remaining tools from gentoolkit-dev"
+ elog "are now obsolete/unused with the git based tree."
+ fi
+
# Only show the elog information on a new install
if [[ ! ${REPLACING_VERSIONS} ]]; then
elog