summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-12-15 14:02:18 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-12-15 14:02:42 +0100
commite455ffa8b966365befd7b8a50142bc76209eae45 (patch)
tree362af004715b0efd517fea3c650e468219c18199 /app-portage/golop
parentmail-client/neomutt: Version bump to neomutt-20171215 (diff)
downloadgentoo-e455ffa8b966365befd7b8a50142bc76209eae45.tar.gz
gentoo-e455ffa8b966365befd7b8a50142bc76209eae45.tar.bz2
gentoo-e455ffa8b966365befd7b8a50142bc76209eae45.zip
app-portage/golop: New ebuild
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'app-portage/golop')
-rw-r--r--app-portage/golop/golop-9999.ebuild31
-rw-r--r--app-portage/golop/metadata.xml17
2 files changed, 48 insertions, 0 deletions
diff --git a/app-portage/golop/golop-9999.ebuild b/app-portage/golop/golop-9999.ebuild
new file mode 100644
index 000000000000..9e60869091a0
--- /dev/null
+++ b/app-portage/golop/golop-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+EGO_PN=github.com/klausman/golop
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~x86"
+ EGIT_COMMIT=v${PV}
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="A pure Go re-implementation of genlop"
+HOMEPAGE="https://github.com/klausman/golop"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ dobin ${PN}
+
+ declare -a DOCS
+ DOCS+=( src/${EGO_PN}/README.md )
+ einstalldocs
+}
diff --git a/app-portage/golop/metadata.xml b/app-portage/golop/metadata.xml
new file mode 100644
index 000000000000..9cd9d4eefb09
--- /dev/null
+++ b/app-portage/golop/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>klausman@gentoo.org</email>
+ <name>Tobias Klausmann</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/klausman/golop/issues/</bugs-to>
+ <changelog>https://github.com/klausman/golop/commits/master</changelog>
+ <remote-id type="github">klausman/golop</remote-id>
+ </upstream>
+</pkgmetadata>