summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-09 05:01:49 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-09 05:03:00 -0500
commit88cea83bb4080d5755c5bb1b6f39edd06e2137bb (patch)
tree54c3d1c8a2e3c20fcf29df91197821658e14c7df /app-portage/iwdevtools
parentdev-ruby/rake: fix tests when rake is not installed (diff)
downloadgentoo-88cea83bb4080d5755c5bb1b6f39edd06e2137bb.tar.gz
gentoo-88cea83bb4080d5755c5bb1b6f39edd06e2137bb.tar.bz2
gentoo-88cea83bb4080d5755c5bb1b6f39edd06e2137bb.zip
app-portage/iwdevtools: add 0.12.11
Identical to 0.12.10 beside a minor default config addition. So doing straight-to-stable to avoid extra hassle. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.12.11.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index ae377cd61317..6574c28e8cdb 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.12.10.tar.gz 91518 BLAKE2B 7a017c6666c67903d5a67b77508d8e86578d673b58cc9763fb6a435697e6dca1da15d9aa40a53e1f84c2966976fd3deafe9351992f886ddf130fe4f75637d105 SHA512 d321259334931be9e488bac8f322d0f042c513a4c84a5b656c381ebb51d8fa1fc7bdf3214b64ad9ea9204f3a5f4dee485325190f8d9a29e918a8cc209d108e8f
+DIST iwdevtools-0.12.11.tar.gz 91626 BLAKE2B ffdc58c9a76105031b3be771d49d3b1afa7550333bc8cc2eae6a8ba798974e363aecf6c3f7f3f76e6d0cf6e3aac1ccd6f73bfafe3f0ae99987099fb3896ecb0f SHA512 6083a7ddef331b8f7ef96491c438096b7c920dedbe2ba3f0d74e6542592cfabbe442939609f10cddce736c21d02794900e8428c10b2b2b46ed988f6efe80351b
diff --git a/app-portage/iwdevtools/iwdevtools-0.12.11.ebuild b/app-portage/iwdevtools/iwdevtools-0.12.11.ebuild
new file mode 100644
index 000000000000..43c7fdf45013
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.12.11.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools/"
+SRC_URI="
+ https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1:0[readline]
+ dev-libs/libxml2:2
+ sys-apps/coreutils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )
+"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}