summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-08-19 07:48:02 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-08-19 07:57:24 -0400
commitce952d0b8e0c5ff4df4e939f51ca85d1daf1649d (patch)
tree68be779d69427f397af1dec1aca388977148040b /app-portage/iwdevtools
parentdev-python/cleo: Add python@ as co-maint. (diff)
downloadgentoo-ce952d0b8e0c5ff4df4e939f51ca85d1daf1649d.tar.gz
gentoo-ce952d0b8e0c5ff4df4e939f51ca85d1daf1649d.tar.bz2
gentoo-ce952d0b8e0c5ff4df4e939f51ca85d1daf1649d.zip
app-portage/iwdevtools: add 0.11.7, straight-to-stable
qa-sed could mangle installed files when using sed labels and not passing them within the same `-e` they're used in (fortunately, only known case is sys-apps/shadow and only resulted in harmless duplicate login.defs comments -- labels isn't a widespread practice) Even if minor here, potential mangling cases is something been trying to avoid as much as possible, so doing straight-to-stable Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.11.7.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 9dd8555ce4d7..9fca2b41b2eb 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.11.6.tar.gz 85945 BLAKE2B 61c18ae0ed1c0f7e90d41af485f18f891cdd9ffbaff5437cb9f9ca88622efa0f5acd89ac8596e7d41c25a083a970143f3b226284f4566b0b8ee3718071cd6cbb SHA512 21ffda72945947658bf6867bf83d9b9ad4f6b930d4c2cee3dea551581030668ab286a4c4a07edeae937fd91f4aba08fe8e7c6506459808c4ada38502226b5b26
+DIST iwdevtools-0.11.7.tar.gz 86578 BLAKE2B 1945f99ab5d516bdef7081e13ecb0921728497f84e5e5248b2ddea78b306f185a0952a664165b4bae6c2089ddd1a4423d26524f42631a53b75fd2749a6994721 SHA512 fe18a88d166f239581bdddb0c719bf1d7789f671df151d87844b1836d134754d731114250ae2a9ef5b1a37a403615c15bbd6174eeeec3fe275e93c32ce6fae5c
diff --git a/app-portage/iwdevtools/iwdevtools-0.11.7.ebuild b/app-portage/iwdevtools/iwdevtools-0.11.7.ebuild
new file mode 100644
index 000000000000..4c53d2af1ea3
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.11.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~loong ppc ppc64 ~riscv sparc x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1
+ dev-libs/libxml2:2
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}