summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /app-portage/layman
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/layman')
-rw-r--r--app-portage/layman/layman-2.0.0-r1.ebuild3
-rw-r--r--app-portage/layman/layman-2.0.0-r3.ebuild3
-rw-r--r--app-portage/layman/layman-2.2.0-r7.ebuild1
-rw-r--r--app-portage/layman/layman-2.4.1-r1.ebuild1
-rw-r--r--app-portage/layman/layman-2.4.2-r1.ebuild1
-rw-r--r--app-portage/layman/layman-2.4.2-r2.ebuild1
-rw-r--r--app-portage/layman/layman-9999.ebuild1
7 files changed, 9 insertions, 2 deletions
diff --git a/app-portage/layman/layman-2.0.0-r1.ebuild b/app-portage/layman/layman-2.0.0-r1.ebuild
index c01d9a93e3ec..cfba5b52cd7f 100644
--- a/app-portage/layman/layman-2.0.0-r1.ebuild
+++ b/app-portage/layman/layman-2.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -16,6 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="bazaar cvs darcs +git mercurial subversion test"
+RESTRICT="!test? ( test )"
DEPEND="test? ( dev-vcs/subversion )"
diff --git a/app-portage/layman/layman-2.0.0-r3.ebuild b/app-portage/layman/layman-2.0.0-r3.ebuild
index a26236066a7c..e2e6e9df396d 100644
--- a/app-portage/layman/layman-2.0.0-r3.ebuild
+++ b/app-portage/layman/layman-2.0.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -16,6 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="bazaar cvs darcs +git mercurial subversion test"
+RESTRICT="!test? ( test )"
DEPEND="test? ( dev-vcs/subversion )"
diff --git a/app-portage/layman/layman-2.2.0-r7.ebuild b/app-portage/layman/layman-2.2.0-r7.ebuild
index 6f50f4f8f3f7..00fc4d1dd541 100644
--- a/app-portage/layman/layman-2.2.0-r7.ebuild
+++ b/app-portage/layman/layman-2.2.0-r7.ebuild
@@ -16,6 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="bazaar cvs darcs +git g-sorcery mercurial squashfs subversion test"
+RESTRICT="!test? ( test )"
DEPEND="test? ( dev-vcs/subversion )"
diff --git a/app-portage/layman/layman-2.4.1-r1.ebuild b/app-portage/layman/layman-2.4.1-r1.ebuild
index 77bc20805a86..398b9adf8cd8 100644
--- a/app-portage/layman/layman-2.4.1-r1.ebuild
+++ b/app-portage/layman/layman-2.4.1-r1.ebuild
@@ -16,6 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86"
IUSE="bazaar cvs darcs +git gpg g-sorcery mercurial sqlite squashfs subversion sync-plugin-portage test"
+RESTRICT="!test? ( test )"
DEPEND="test? ( dev-vcs/subversion )
"
diff --git a/app-portage/layman/layman-2.4.2-r1.ebuild b/app-portage/layman/layman-2.4.2-r1.ebuild
index 46f0b1bd942d..9662dd128474 100644
--- a/app-portage/layman/layman-2.4.2-r1.ebuild
+++ b/app-portage/layman/layman-2.4.2-r1.ebuild
@@ -16,6 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="bazaar cvs darcs +git gpg g-sorcery mercurial sqlite squashfs subversion sync-plugin-portage test"
+RESTRICT="!test? ( test )"
DEPEND="test? ( dev-vcs/subversion )
"
diff --git a/app-portage/layman/layman-2.4.2-r2.ebuild b/app-portage/layman/layman-2.4.2-r2.ebuild
index 52df5e51656a..1d63b0e05f54 100644
--- a/app-portage/layman/layman-2.4.2-r2.ebuild
+++ b/app-portage/layman/layman-2.4.2-r2.ebuild
@@ -22,6 +22,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Layman"
LICENSE="GPL-2"
SLOT="0"
IUSE="bazaar cvs darcs +git gpg g-sorcery mercurial sqlite squashfs subversion sync-plugin-portage test"
+RESTRICT="!test? ( test )"
DEPEND="test? ( dev-vcs/subversion )
"
diff --git a/app-portage/layman/layman-9999.ebuild b/app-portage/layman/layman-9999.ebuild
index 52df5e51656a..1d63b0e05f54 100644
--- a/app-portage/layman/layman-9999.ebuild
+++ b/app-portage/layman/layman-9999.ebuild
@@ -22,6 +22,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Layman"
LICENSE="GPL-2"
SLOT="0"
IUSE="bazaar cvs darcs +git gpg g-sorcery mercurial sqlite squashfs subversion sync-plugin-portage test"
+RESTRICT="!test? ( test )"
DEPEND="test? ( dev-vcs/subversion )
"