summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/maintainer-helper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/maintainer-helper')
-rw-r--r--app-portage/maintainer-helper/Manifest1
-rw-r--r--app-portage/maintainer-helper/maintainer-helper-0.1.2.ebuild34
-rw-r--r--app-portage/maintainer-helper/metadata.xml7
3 files changed, 42 insertions, 0 deletions
diff --git a/app-portage/maintainer-helper/Manifest b/app-portage/maintainer-helper/Manifest
new file mode 100644
index 000000000000..0d310dea00a6
--- /dev/null
+++ b/app-portage/maintainer-helper/Manifest
@@ -0,0 +1 @@
+DIST maintainer-helper-0.1.2.tar.bz2 99698 SHA256 820213b6699f5c19df8a0e69537e9197947021c55f9843e3061322e27a678b97 SHA512 a33418ff84290d1d7deed789f3a45c8d9d635f06a69257713b37983158c363c631002d85a68dbfccf94df400cf04059eba670e115aa474ee8ec0474627a58343 WHIRLPOOL 46438c70f0a1d595188a0643b5eac9e6c7af390b013058f5fd6e3f12ade8cdf62c6b67cb6688736162af88370f18701a80661d0bf638c3cd6f665a94cc8588ee
diff --git a/app-portage/maintainer-helper/maintainer-helper-0.1.2.ebuild b/app-portage/maintainer-helper/maintainer-helper-0.1.2.ebuild
new file mode 100644
index 000000000000..3247e485941e
--- /dev/null
+++ b/app-portage/maintainer-helper/maintainer-helper-0.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="An application to help with ebuild maintenance"
+HOMEPAGE="http://dev.gentoo.org/~jokey/maintainer-helper"
+SRC_URI="http://dev.gentoo.org/~jokey/maintainer-helper/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-qt/qtgui:4
+ >=dev-python/PyQt4-4.2[X]
+ >=sys-apps/pkgcore-0.3.1
+ >=dev-python/snakeoil-0.1_rc2"
+
+PYTHON_MODNAME="maintainer_helper"
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ elog "Currently gvim is hardcoded as editor, to change it, edit"
+ elog "${EROOT}$(python_get_sitedir -b -f)/maintainer_helper/backend/tasks.py"
+ elog "It will be a real setting in the next version"
+}
diff --git a/app-portage/maintainer-helper/metadata.xml b/app-portage/maintainer-helper/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/app-portage/maintainer-helper/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>