summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2019-07-20 16:49:57 +0200
committerDaniel Pielmeier <billie@gentoo.org>2019-07-20 16:49:57 +0200
commit11d00493e4b04ed98715b2d0f93286a77d63bf54 (patch)
tree2f030f567b727cdc85b17286b1df2ffb4c381f74 /app-portage/pfl
parentvirtual/lapack: add openblas as a lapack provider. (diff)
downloadgentoo-11d00493e4b04ed98715b2d0f93286a77d63bf54.tar.gz
gentoo-11d00493e4b04ed98715b2d0f93286a77d63bf54.tar.bz2
gentoo-11d00493e4b04ed98715b2d0f93286a77d63bf54.zip
app-portage/pfl: Revision bump to pfl-3.0.1-r2.
This fixes bug #690290. Thanks to Louis Sautier for the report. Signed-off-by: Daniel Pielmeier <billie@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'app-portage/pfl')
-rw-r--r--app-portage/pfl/pfl-3.0.1-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-portage/pfl/pfl-3.0.1-r2.ebuild b/app-portage/pfl/pfl-3.0.1-r2.ebuild
new file mode 100644
index 000000000000..501f62999ba7
--- /dev/null
+++ b/app-portage/pfl/pfl-3.0.1-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de"
+SRC_URI="https://dev.gentoo.org/~billie/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ >=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]
+ net-misc/curl
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/util-linux[caps]
+"
+
+PATCHES=(
+ "${FILESDIR}/e-file-function.patch"
+)
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ keepdir /var/lib/${PN}
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT}/var/lib/${PN}/pfl.info" || die
+ fi
+ chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
+ chmod 775 "${EROOT}/var/lib/${PN}" || die
+}