summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-03-21 18:13:06 -0400
committerMike Pagano <mpagano@gentoo.org>2018-03-21 18:13:15 -0400
commitd327567921df3696258b70b829bb64cd94a1abb7 (patch)
treedb2a612cf340303ab8bd1a323fa65510caca03dc /app-portage/portpeek
parentnet-libs/libsoup-2.58.2: fix unaligned accesses (diff)
downloadgentoo-d327567921df3696258b70b829bb64cd94a1abb7.tar.gz
gentoo-d327567921df3696258b70b829bb64cd94a1abb7.tar.bz2
gentoo-d327567921df3696258b70b829bb64cd94a1abb7.zip
app-portage/portpeek: Restoring
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-portage/portpeek')
-rw-r--r--app-portage/portpeek/portpeek-2.1.26.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-portage/portpeek/portpeek-2.1.26.ebuild b/app-portage/portpeek/portpeek-2.1.26.ebuild
new file mode 100644
index 000000000000..06eb5a6cda32
--- /dev/null
+++ b/app-portage/portpeek/portpeek-2.1.26.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="http://www.mpagano.com/blog/?page_id=3"
+SRC_URI="http://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.4.0
+ || (
+ >=sys-apps/portage-2.3.19-r1[${PYTHON_USEDEP}]
+ )"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}