summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-03-29 00:55:56 -0700
committerZac Medico <zmedico@gentoo.org>2021-03-29 00:59:47 -0700
commit6b061f1f7641c028c57f57bbd91997c6cf646b9a (patch)
tree45a71bf6c1d9df4090fd20b80057d9596d0264c1 /app-portage/repoman
parentgames-emulation/mgba: Removed old (diff)
downloadgentoo-6b061f1f7641c028c57f57bbd91997c6cf646b9a.tar.gz
gentoo-6b061f1f7641c028c57f57bbd91997c6cf646b9a.tar.bz2
gentoo-6b061f1f7641c028c57f57bbd91997c6cf646b9a.zip
app-portage/repoman: Bump to version 3.0.3
#608664 variable.phase check like pkgcheck VariableScopeChec #692486 Change message for preserve_old_lib Bug: https://bugs.gentoo.org/608664 Bug: https://bugs.gentoo.org/692486 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-portage/repoman')
-rw-r--r--app-portage/repoman/Manifest1
-rw-r--r--app-portage/repoman/repoman-3.0.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/repoman/Manifest b/app-portage/repoman/Manifest
index 84a64fb90952..0a73ad918689 100644
--- a/app-portage/repoman/Manifest
+++ b/app-portage/repoman/Manifest
@@ -1,2 +1,3 @@
DIST repoman-2.3.23.tar.bz2 87108 BLAKE2B c1190433bd8aedf59e1ddf192dd14cca13e3bdae7367decd6bf64a79021f54a63f21ec49d5737b90c46be3894f4d3ff11bf5bd2868c9ebf65e44b4eb3bb4eee0 SHA512 9d01fadc5820501a9bfb9c1b6d9634ecbc14aacdc448bb440d1e37d47f7e4bcdea8269f8ba90e3783d84f31121870a9d7b165f58b78f0d0f0f4e822a25687d1b
DIST repoman-3.0.2.tar.bz2 88258 BLAKE2B 32c4d6750fd225cf9fc071be0ffbb38563ffdaf50f1f1ac7247ce3733bd781cd699052101df8b6565fd3d32ec6d9a54efb611b815a722b7954d8100ce01de146 SHA512 fd5b4549a0b108ed1ad37fc0766fc73db127bba8b023a74566ee0167e2a9c56c8597b83ead16522aaf84f158a9a5d0d59e4b5bcc908e6024724c087c837e1fa2
+DIST repoman-3.0.3.tar.bz2 90373 BLAKE2B a4ea542c452d44b1f4aef235d67390b0a0f139f32da33ab9ad8992797965724f4ef8123a49b681e9205b6e3fe279dd248b65b0119659b7a0038fe9884bec0797 SHA512 09855a8a0098482c1ce0a7f50d2481528e713fb6796a4004475c841de59f9df8d264f2e9342fdaee87c71d275137234b7e3adc3454f7f33dcf75e32a0ae3f0e9
diff --git a/app-portage/repoman/repoman-3.0.3.ebuild b/app-portage/repoman/repoman-3.0.3.ebuild
new file mode 100644
index 000000000000..d6e3b5298989
--- /dev/null
+++ b/app-portage/repoman/repoman-3.0.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE='bzip2(+)'
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
+ S="${WORKDIR}/${P}/repoman"
+else
+ SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/portage-3.0.18[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog ""
+ elog "This release of repoman is from the new portage/repoman split"
+ elog "release code base."
+ elog "This new repoman code base is still being developed. So its API's"
+ elog "are not to be considered stable and are subject to change."
+ elog "The code released has been tested and considered ready for use."
+ elog "This however does not guarantee it to be completely bug free."
+ elog "Please report any bugs you may encounter."
+ elog ""
+ fi
+}