summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2020-12-02 18:16:06 +0100
committerSam James <sam@gentoo.org>2020-12-02 22:38:57 +0000
commit76f5d26eaf5c5abc424056255b72cd13d335b29c (patch)
treef7eb4d4cf5b71405f57e0abd93823c2a32dd2be2 /app-portage/tatt
parentmedia-libs/a52dec: drop to ~hppa (diff)
downloadgentoo-76f5d26eaf5c5abc424056255b72cd13d335b29c.tar.gz
gentoo-76f5d26eaf5c5abc424056255b72cd13d335b29c.tar.bz2
gentoo-76f5d26eaf5c5abc424056255b72cd13d335b29c.zip
app-portage/tatt: version bump 0.8
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage/tatt')
-rw-r--r--app-portage/tatt/Manifest1
-rw-r--r--app-portage/tatt/tatt-0.8.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-portage/tatt/Manifest b/app-portage/tatt/Manifest
index c236134700c4..de293be8cce3 100644
--- a/app-portage/tatt/Manifest
+++ b/app-portage/tatt/Manifest
@@ -1 +1,2 @@
DIST tatt-0.7.tar.gz 21802 BLAKE2B a0195f253e2777a8756fd7d1f83804bf3a4ca90fdeb07b2f8dc28dcb6f1d1f3c47fd948e0d001103f7972dc8cb8ee45a237dd24b3dc149392aa9841fe3d6532a SHA512 1f2a144512801d50585d40074553049ebd08bc5f084a0623b89d901acb9448657e7f42f2c8da5f613e0b2ff5c3fe59fbada1ad911c9693846923e256a2e97ecd
+DIST tatt-0.8.tar.gz 22215 BLAKE2B 6c21acb9378045679c4a03badcb7c60638c4007ba19857d7519f68d4d658cd1418e952cf15a64679c6a9b28090856a588e60e9db1abb360d0625a633491deb3d SHA512 31be6573e3d7c9a690e57d64adcbf87983d5dd226afd162c7bfa425847a84705beda530cd5b648ac85cf8cd3907d46ae638bb0ca0d903d8d1968d0ac30703703
diff --git a/app-portage/tatt/tatt-0.8.ebuild b/app-portage/tatt/tatt-0.8.ebuild
new file mode 100644
index 000000000000..4966a0e29da0
--- /dev/null
+++ b/app-portage/tatt/tatt-0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Arch testing tool"
+HOMEPAGE="https://github.com/gentoo/tatt"
+SRC_URI="https://github.com/gentoo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+templates"
+
+RDEPEND="
+ app-portage/eix
+ app-portage/gentoolkit[${PYTHON_USEDEP}]
+ app-portage/nattka[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-client/pybugz
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use templates; then
+ insinto "/usr/share/${PN}"
+ doins -r templates
+ fi
+ doman tatt.1
+ doman tatt.5
+}