summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-10 15:46:47 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-10 15:50:38 +0100
commit8c988da5080da0451d832ced87573779556c03bb (patch)
treeb0af3302983e96da56467cb99670a0c085bd99d6 /app-portage/unsymlink-lib
parentwww-plugins/adobe-flash: Old. (diff)
downloadgentoo-8c988da5080da0451d832ced87573779556c03bb.tar.gz
gentoo-8c988da5080da0451d832ced87573779556c03bb.tar.bz2
gentoo-8c988da5080da0451d832ced87573779556c03bb.zip
app-portage/unsymlink-lib: Bump to v12, with improved error handling
Bump to v12. The new version improves error handling even more, and officially starts supporting sub-mounts (and subvolumes) inside the migrated tree. Well, more specifically -- it informs the user of pending doom and helps him recover from it. Closes: https://bugs.gentoo.org/643194
Diffstat (limited to 'app-portage/unsymlink-lib')
-rw-r--r--app-portage/unsymlink-lib/Manifest1
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-12.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-portage/unsymlink-lib/Manifest b/app-portage/unsymlink-lib/Manifest
index ffc84aef2eb8..e6822dd37668 100644
--- a/app-portage/unsymlink-lib/Manifest
+++ b/app-portage/unsymlink-lib/Manifest
@@ -1,3 +1,4 @@
DIST unsymlink-lib-10.tar.gz 8710 BLAKE2B 23c3e483f57480ffdc73a6fe4a16f3956c4e402f8490ae0a0f35659e3b1f3acf4f76e4ae8ea8f9b538d5c5f7226be7d72a735f12174329cde5e895b80af9063e SHA512 a00bed24336b9cec5870c43723b236ecf3e847e21c64ef5a119a31bc98adf4bd4b43594be423c593c1cf104fd3de41e91398bf0920eca57339a1e12768855a3b
DIST unsymlink-lib-11.tar.gz 8766 BLAKE2B 786870765ad065c58e539dafed63f350c4fc251552f44ad8cd1d2bdca12295f5db859d01143e5bdcbd61806433a57961e9b0c0852919b656804cc4cefbb2b621 SHA512 afd5ad53812ea4bfe60a42b05fdac6059042519fc438e69dc76168104c0e39b49374c8bda278c3901e88f137b4f051f2c4648f1d7a190d8755e8d6ac2717ab1f
+DIST unsymlink-lib-12.tar.gz 8689 BLAKE2B 3c170886bfa3980ef0d51be1e3636afcd700aad94514a2783a1bf221970022fb4812640ac0c2f54e6b0d3b93244a64221b092768425faa1ddcfdc21ba76d9cd1 SHA512 e964cf8dae4107cbe0f5a304e693794d50316b914cca6cdf068ac3e715c8a6fab44d96ec38bd34e5c4f65dd169629bcaca3a0b6ce3256c3d40dbff69dac56fe5
DIST unsymlink-lib-9.tar.gz 8695 BLAKE2B 436c1f62a608ba016e1b4de6c998fe9667a22f345b9be68fe10e584a39a3389049d511615ecf9fe6e6845fc199082af68066dc71e6cb8edb43222480833e1d24 SHA512 24bf1a2c6a0cf7336f343617ddefe2fb56e39efbf5278d432abd282a41e001130fe227efee2c3ccd0d66661b74a7a4dbc241f7e208be1c54844a7a612aabf28d
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-12.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-12.ebuild
new file mode 100644
index 000000000000..6ca4f9fdb17b
--- /dev/null
+++ b/app-portage/unsymlink-lib/unsymlink-lib-12.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sys-apps/portage[${PYTHON_USEDEP}]"
+
+src_install() {
+ python_doscript unsymlink-lib
+ dodoc README
+}